2

Running 16.04 on a Dell Vostro 1500 with a Broadcom BCM4311 (rev 01).

I booted up recently and was unable to connect via WiFi.

I get the message that 'Wifi networks are available' but cannot connect to mine.

The issue manifests as being queried for the WPA2 password but then timing out once it's supplied, or after 1+ minute of trying to connect, again being queried for the password. The WiFi icon sometimes loses its 'bars' and becomes unresponsive after a few attempts.

The password has been triple checked and is used on many other devices.

The wifi adapter is switched on and recognised by the OS.

It is not hard or soft blocked.

I've tried the following:

sudo apt update
sudo update-pciids
sudo apt-get purge bcmwl-kernel-source 

(all tutorials/past questions said this must be done. I got the response that bcmwl-kernel-source had not been installed.)

sudo apt-get install --reinstall bcmwl-kernel-source

(at this point after rebooting, I could not connect via ethernet to my network)

sudo apt-get purge bcmwl-kernel-source

(after rebooting, I could now connect via ethernet)

sudo apt install firmware-b43-installer

(returned message that it is already installed)

sudo apt-get remove --purge firmware-b43-installer
sudo apt install firmware-b43-installer

After reinstalling firmware-b43-installer and rebooting, the problem remains.

I'm unsure what my next step should be. The laptop sees the wifi adapter, the adapter sees my network, but I can no longer connect to it.

Thank you for any assistance.

  • May we see: sudo iwlist scan. We are only interested in your access point; trim away all the others. Obscure the MAC address (but NOT the SSID) with xxx. We also need: dmesg | grep -e wlp -e b43. b43 and firmware are correct for your device and bcmwl-kernel-source is definitely not. As the result may be lengthy, post it here and give us the link: paste.ubuntu.com – chili555 Dec 14 '16 at 16:36
  • @chili555 Thank you for your response, here is the link: paste.ubuntu.com/23629605 – pkd Dec 14 '16 at 16:55
1

In your paste, we see:

IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK

Many Linux drivers are troubled with TKIP. As well, it is reported to be less secure than WPA2-AES, also known as CCMP.

Please check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

Reboot and tell us if connectivity is improved.

| improve this answer | |
  • You are quite right: it was my router config. It was set to n only, which I changed to n/g/b; and WPA, which I changed to "WPA2 only" and changed the cypher from "Both" to AES. It was still set fixed at channel 6 (no auto); however, I can see that it is set to 20/40Mhz channel width. After much searching through forums, this particular make/model allows you to change this as a Mbps setting 130/270/"Force 300" Mbps (but no info about corresponding Mhz values). Regulatory domain is fine. Believe this was a result of a pushed firmware update. Works now, huge thanks for your expertise! – pkd Dec 14 '16 at 22:12
  • Awesome! If my answer has been helpful, please accept it: askubuntu.com/tour – chili555 Dec 14 '16 at 22:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.