2

I was wondering if it is possible to just disable the password authentication.

It is getting tedious to install everything when I'm being asked to enter my password what feels like every two seconds.

4

Go to your 'System settings...'(at the extreme right-hand corner of your screen and click on power icon to find it). Select 'User Accounts' and click 'Unlock' at the top right corner of the dialogue box and enter your password to unlock it and set the 'Automatic Login' to ON.Close and restart your system.

If that doesn't help, then do the following at terminal:

  1. sudo visudo

  2. look for this line admin ALL=(ALL) ALL (probably close to the last line).

  3. replace it with admin ALL=(ALL) NOPASSWD: ALL.

  4. Save and exit.

1
  • 1
    Restart is not required, changes take effect immediately.
    – Panther
    Dec 8 '11 at 2:37
2

You should not have to enter a password every 2 seconds, but I understand the annoyance.

I personally do sys admin from a root shell

sudo -i

You can start graphical applications with gksu

gksu nautilus
gksu gedit /path/to/file/to/edit

The other feature that annoys people sometimes is gnome-keyring. Several solutions to that, including setting an empty password (for gnome key ring)

See : How to disable GNOME keyring?

If you must , you can configure sudo so that a password is not required, but understand the security implications if you choose to do so.

This is the classic link for additional information on sudo and additional options

RootSudo

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.