3

Using Intel AC 8260, subsystem 0010 (included in lspci below).

I installed ubuntu 16.10 on my new clevo P775DM3-G Laptop yesterday and wifi was working. Well i had to turn bluetooth off, then wifi showed networks, connect to one of them and then turn bluetooth on back and everything worked.

I put machine to sleep and in the morning today, opening it back everything was jumbled (distorted display and keys not working) so had to hard reset and now wifi does not work any more - does not detect any network around. How do i get it back up ?

uname -r
4.8.0-30-generic

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.10
Release:        16.10
Codename:       yakkety

For lshw (The wireless reads disabled, that should be of concern ? ):

sudo lshw -C network
  *-network
       description: Ethernet interface
       product: Killer E2400 Gigabit Ethernet Controller
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:6d:00.0
       logical name: enp109s0
       version: 10
       serial: 80:fa:5b:3a:e9:2b
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=alx duplex=full ip=192.168.0.2 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:122 memory:dc400000-dc43ffff ioport:d000(size=128)
  *-network DISABLED
       description: Wireless interface
       product: Wireless 8260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:70:00.0
       logical name: wlp112s0
       version: 3a
       serial: a4:34:d9:ee:3e:69
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.8.0-30-generic firmware=22.361476.0 latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:124 memory:dc100000-dc101fff

For lspci:

lspci -vnn | grep -A 10 -B 10 -i wifi
        Memory at dc200000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: nvme
        Kernel modules: nvme

70:00.0 Network controller [0280]: Intel Corporation Wireless 8260 [8086:24f3] (rev 3a)
        Subsystem: Intel Corporation Dual Band Wireless-AC 8260 [8086:0010]
        Flags: bus master, fast devsel, latency 0, IRQ 124
        Memory at dc100000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: <access denied>
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi

For rfkill:

rfkill list
0: hci0: Bluetooth
        Soft blocked: yes
        Hard blocked: no
2: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

Edit 1: I definitely think this is something to do with the failed suspend-resume. I tried suspend resume again and it froze like the last time. However i pressed Ctrl-Alt-F1 followed by Ctrl-Alt-F7 (I used to do this on 14.04 when desktop used to freeze like every couple of hrs with Nvidia 860M to get it to unfreeze again) and after 2 min it recognised the Ctrl-F1 the screen went blank, and then after more 2 min the Ctrl-F7 got it back and everything worked and i logged in. The wifi was enabled and detected connections once more. To confirm (out of habit) i suspended & resumed once again, same problem, pressed Ctrl-Alt-F1 followed by Ctrl-Alt-F7, but this time it froze for good and after 10 min, did a hard reset. Now back to square one - wifi no longer works, lshw shows it's disabled like before :( . Don't know if this is related: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1566302/comments/123

Also here is the requested dmesg: http://paste.ubuntu.com/23625894/

And here is my current graphics card in case it helps anyone figure out what's wrong:

lspci -vnn | grep -A 10 -B 10 -i "\(nvidia\)\|\(vga\)"
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-H SMBus [8086:a123] (rev 31)
    Subsystem: CLEVO/KAPOK Computer Sunrise Point-H SMBus [1558:7705]
    Flags: medium devsel, IRQ 255
    Memory at 2ffff24000 (64-bit, non-prefetchable) [size=256]
    I/O ports at f000 [size=32]
    Kernel modules: i2c_i801

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106M [GeForce GTX 1060] [10de:1c60] (rev a1) (prog-if 00 [VGA controller])
    Subsystem: CLEVO/KAPOK Computer Device [1558:7706]
    Flags: bus master, fast devsel, latency 0, IRQ 122
    Memory at db000000 (32-bit, non-prefetchable) [size=16M]
    Memory at 90000000 (64-bit, prefetchable) [size=256M]
    Memory at a0000000 (64-bit, prefetchable) [size=32M]
    I/O ports at e000 [size=128]
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: nvidia
    Kernel modules: nvidiafb, nouveau, nvidia_370, nvidia_370_drm

01:00.1 Audio device [0403]: NVIDIA Corporation Device [10de:10f1] (rev a1)
    Subsystem: CLEVO/KAPOK Computer Device [1558:7706]
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at dc080000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

Edit 2: After downloading and installing a fresh copy of firmware as asked by @chili555, here is the new dmesg: http://paste.ubuntu.com/23625981/

(The problem still exists)

2

In your paste, we see a microcode (firmware) error. We wonder if your firmware file is corrupted. Let's download and install a fresh copy. From the terminal with a working internet connection:

wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.162_all.deb
sudo dpkg -i linux*.deb

Reboot and let us see a new paste:

dmesg | grep iwl

This page suggests that the firmware for kernel versions 4.3 and newer is the -16 version. Your driver loads -22. Let's experiment by renaming -21 and -22 to try to load -16 and see if it helps.

cd /lib/firmware
sudo mv iwlwifi-8000C-21.ucode  iwlwifi-8000C-21.bak
sudo mv iwlwifi-8000C-22.ucode  iwlwifi-8000C-21.bak

Reboot and let us have a paste.

dmesg | grep iwl
  • Did that and added dmesg output in Edit 2 in the question. Just a question, i have no idea what i just did (the thing that you asked me above) - so at the end if things still don't work do i have to undo what you asked me to do ? If yes pls let me know how to do it too :) – ustulation Dec 13 '16 at 22:44
  • Please see my edit in a few moments. – chili555 Dec 13 '16 at 23:18
  • I got it working by nmcli r wifi off && nmcli r wifi on - i don't know if that is temporary. Do you still want me to try what you are suggesting or leave it at this ? – ustulation Dec 13 '16 at 23:27
  • No, you are absolutely right ! nmcli thingy i wrote was only temporary. It again happened randomly on reboots and definitely on hard-resets after suspend-resume failures. I renamed the -21 and -22 files in /lib/firmware as you suggested and now in sudo lshw -C network i can see firmware=16.242414.0 loaded. Now it works all the time, though suspend resume is still a problem and freezes - aparantly that is something to do with iwconfig power management conflicts or something form here askubuntu.com/a/847688/542532 Anyway thanks a ton ! So is there anything you want me to do next – ustulation Dec 14 '16 at 1:07
  • And here is the new dmesg : paste.ubuntu.com/23626446 It's much shorter (hope that is good though :| ) – ustulation Dec 14 '16 at 1:14
2

So after Edit 1 and 2 in the question i started looking into different directions and finally found this: https://askubuntu.com/a/608897/542532

Taking a hint from there i just executed

:~$ nmcli r wifi off && nmcli r wifi on

and now wifi seems to be back :)

I'll still wait for sometime to see if this does indeed solve it.

Edit: This was only temporary and the problem reappeared after reboot - see @chili555's answer, that's turned out to be far more useful.

0

Follow these commands:

sudo service network-manager restart

then

sudo ip link set wlp112s0 up
  • sudo service network-manger restart gives Failed to restart network-manger.service: Unit network-manger.service not found. – ustulation Dec 13 '16 at 19:34
  • 2
    I think he means: sudo service network-manager restart Not manger but manager. – chili555 Dec 13 '16 at 20:28
  • Are not the commands in the inverse order? – user308164 Dec 13 '16 at 20:35
  • sudo service network-manager restart ran but did nothing. sudo ip link set wlp112s0 up errored: RTNETLINK answers: Input/output error – ustulation Dec 13 '16 at 22:10
  • there is any error in dmesg | grep firmware – Tarunkant Gupta Dec 14 '16 at 3:36
0

Try to check your logs by runnning sudo journalctl and you should see what happened between it working and stopping.

Add the -b argument to get the output of the current boot only. What you want to see is network manager, which you can view by entering journalctl -u NetworkManager

You can also display kernel messages with the -k argument, and if your hardware is very new, you could try different kernels to understand if it changes the behaviour of network manager. Kernel 4.9 is out, check how to install it here: http://ubuntuhandbook.org/index.php/2016/12/install-linux-kernel-4-9-ubuntu-linux-mint/

  • sudo journalctl -u NetworkManager was a huge output - but there are a few lines marked as error in red saying <error> [1481664444.2145] sup-iface[0x55860b80f1f0,wlp112s0]: error adding interface: wpa_supplicant couldn't grab this interface. and <error> [1481664266.3065] platform-linux: do-change-link[3]: failure changing link: failure 5 (Input/output error) and nm_device_get_device_type: assertion 'NM_IS_DEVICE (self)' failed for instance. – ustulation Dec 13 '16 at 22:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.