0

I just got a new external hard drive WD My Passport 0820, it works perfectly fine on windows, but on ubuntu it says unable to mount, while on windows it mounts perfectly. I've tried formatting the drive with ntfs-3g it gives the following error:

Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... FAILED
Error: Failed to fix the alternate boot sector

I've ran chkdsk /f, chkdsk /r they all say your drive contains no error, on disk management on windows it reads as healthy partition,on gparted it reads as unknown, i've tried every possible answer relating to this issue online but still can't find a solution. Please i need help, how do i fix this error?

p.s: it's NTFS

  • Did you install ntfs-3g on your Linux side? – Videonauth Dec 13 '16 at 18:24
  • yes i did that's how i ran the sudo ntfsfix /dev/sdb1 – codex Dec 13 '16 at 18:27
  • 1
    Shut down Windows without hibernation - Windows hibernation leaves NTFS disks inconsistent. Get Windows to power off. – waltinator Dec 13 '16 at 18:46
  • @waltinator it's not a windows disk, it's an external hard drive – codex Dec 13 '16 at 18:57
  • The filesystem is NTFS. Native to Windows. Secret Source. – waltinator Dec 13 '16 at 19:46
0

I doubt ntfs-3g is the most reliable tool to fix and/or format an NTFS partition. Since you have a Windows OS at hand, have Windows check / reformat your NTFS partition. Worked for me in the past.

  • Done that, it works on windows but not on ubuntu – codex Dec 13 '16 at 19:19
  • Apparently, since ntfs-3g tries to fix the disk, it is not properly unmounted on Windows – xhienne Dec 14 '16 at 13:50
0

Just try out what @waltinator said once. Go to command prompt in windows and type

$ shutdown /s

This will completely shut down windows and on restart hard disks mount properly in ubuntu. I had a similar problem and it got resolved this way.

  • Just did it didn't work still – codex Dec 13 '16 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.