4

I installed Ubuntu with a fully LUKS encrypted LVM.

It works fine with one issue: After selecting Ubuntu in Grub while booting, the "enter passphrase to unlock disk" screen does not show up. I can (blindly) type my password into the black screen and it works. After a few seconds the normal boot stuff happens and everything is fine.

But I wonder why I get nothing on my screen.

The first 2-3 times after installation it worked as expected but at some point the over the last few days the screen stayed black. (I can't really say what I've done that caused it..)

This is my /etc/default/grub file:

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="kopt=root=/dev/mapper/vgubuntu-root quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
  • You can try to add your graphics modesetting driver to initramfs. Check /etc/initramfs-tools/modules – Andrius Štikonas Dec 15 '16 at 16:24
  • I see you signed on a month ago. Can you answer this 16 month old question you posted? If you don't remember how it got fixed can you delete this question? If it's still an on-going problem can you let me know? Thanks. – WinEunuuchs2Unix Apr 26 '18 at 0:53
  • Firstly, sorry for not answering to the original reply. @WinEunuuchs2Unix how to i find out my graphics modesetting driver? Another thing I noticed: When I restart my PC (even restart while botting) the screen is there, just when I start the machine from a shutdown state it's gone. – Graslandpinguin Apr 28 '18 at 11:43
0

In your grub configuration you will notice a line containing "quiet splash":

  • quiet suppresses annoying scrolling messages on the boot screen.
  • splash loads the plymouth graphical boot theme display that is also responsible for prompting for the LUKS password.

Since Ubuntu 17.10 came out there has been a bug in Plymouth where the LUKS password prompt has been broken.

I suggest you visit the Launchpad bug report here. Sign up to indicate the bug effects you. Also sign up for the "bug mail" to be notified when new messages are posted.

This bug also effects Ubuntu 18.04 LTS and Fedora 27.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.