1

I just upgraded to Ubuntu 16.04 from 14.04, and I use Unity.

The gnome-terminal seem to have lost options to control its appearance and it's very disappointing... :(

For example, I checked with screenshots from the previous version, the font appears wider: indeed for fontsize 11, I could fit 93 characters on a row using a half screen, whereas only 80 now...). I am pretty sure there was an option before to control the aspect ratio of the font, and personally I prefer to have more characters on a line...

Has it disappeared forever? Is there a workaround?

Also, now, there is the scrollbar on the right that does not disappear. How to get rid of it?

  • Edit > Profile Preferences, change as desired – doug Dec 12 '16 at 23:59
  • @doug There is not the setting I describe. – PlasmaBinturong Dec 13 '16 at 1:04
  • In 14.04 I see nothing about "aspect ratio of the font", just an option for using the system font or not. So in 16.04 which doesn't have this option set a custom font to suit (if possible). As far as removing scroll bar it's under the Scrolling tab. – doug Dec 13 '16 at 1:33
  • Ok thank you! I'll try to set a custom font. I found the scroll bar setting, didn't search enough... – PlasmaBinturong Dec 13 '16 at 9:57
  • Fontconfig has an aspect property ("Stretches glyphs horizontally before hinting") you can use in fonts.config, implying you can specify a value like 0.8 to increase the height:width ratio, but I can't get it to work. – Adam Katz Oct 26 '17 at 19:42
1

Oh, now I remember how I changed the font aspect ratio in previous Ubuntu versions. I used unity-tweak-tool, exactly as described in this answer (Under Appearance, Fonts, Text scaling factor). Then later I decided unity-tweak-tool was kind of a bad dangerous program and I uninstalled it, that's why I forgot I guess.

I'll try to find if there is a way to do the same without unity-tweak-tool and edit later this answer if so.

For the scrollbar, as @doug said in its comment, it's in Edit > Preferences under the "Scrolling" tab.

[EDIT: How to change the default font with dconf-editor]

Without unity-tweak-tools, dconf-editor does the job, you just need to know where to find the parameter:

  1. Run dconf-editor in a terminal.
  2. navigate to : org > gnome > desktop > interface
  3. Edit the fields monospace-font-name and text-scaling-factor. In my case, I set to 'Ubuntu Mono 12' and 0.9 respectively.
  4. close dconf-editor
  5. in gnome-terminal, open the preferences of your profile, and choose to use the default font.
  • 1
    Adjusting the text-scaling-factor can also be performed in a single command on the command line as follows: gsettings set org.gnome.desktop.interface text-scaling-factor 0.9 – Adam Katz Oct 25 '17 at 21:29
  • text-scaling-factor does not alter the height:width ratio for me. It merely magnifies or shrinks the font proportionally. – Adam Katz Oct 26 '17 at 19:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.