1

I need your help, please!

EDITED! (See below)

I use Ubuntu 16.04 LTS, and my "home folder" is encrypted. When I put on my computer, I insert my "encryption password" and it is well accepted, but Ubuntu never start, and so, the following message appears:

:    2.066866] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
:    2.066887] [drm:intel_pch_fifo_underun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
:    2.082464] [drm:intel_set_cpu_fifo_underrun_reporting [i915]] *ERROR* uncleared fifo underrun on pipe B
:    2.082483] [drm:intel_cpu_fifo_underrun_irq_handdler [i915]] *ERROR* CPU pipe B FIFO underrun
:    2.231106] sd 6:0:0:0: [sdb] No Caching mode page found
:    2.231142] sd 6:0:0:0: [sdb] Assuming drive cache: write thorugh
Welcome to the emergency mode! After logging in, type "journalctl -xb" to view
System logs, "systemctl reboot" to reboot, "systemctl default" or ^D to
Try again to boot into default mode.
Press Enter for maitenance
or press Control-D to continue): _

(I have hand-typed the previous code)

As I don't know how to fix this problem, I wanted to recover my data in an external hard disk by initializing from a LiveUSB (not the same as the hard disk), and so format my computer. But, my new problem is I cannot open my encrypted "home folder".

When I open my encrypted home folder through the LiveUSB (using "sudo nautilus"), I find two files. The first one is "Access-Your-Private-Data.desktop", and, the second one is a *.txt called README which contains the instructions to open my home folder. So, I have two options:

A. [Double click on the file "Access-Your-Private-Data.desktop"]: The problem here is, this file opens a windows (like a terminal) which close immediately, and never ask me for my encryption password.

B. [Type the command "ecryptfs-mount-private" on the terminal]: The problem here is, I obtain the following error:

ubuntu@ubuntu:~$ sudo ecryptfs-mount-private
ERROR: Encrypted private directory is not setup properly

Also, I have used the command "sudo ecryptfs-recover-private", but I obtain the following problem:

ubuntu@ubuntu:~$ sudo ecryptfs-recover-private
INFO: Searching for encrypted private directories (this might take a while)...
find: ‘/run/user/999/gvfs’: Permission denied
find: File system loop detected; ‘/sys/kernel/debug/pinctrl’ is part of the same file system loop as ‘/sys/kernel/debug’.

I hope you can help me. Thank you!

EDIT: Well, finally I fixed the problem. First of all, I had to find the correct directory containing my encrypted "home folder", for that, I typed the following command:

sudo find /media -type d -name .Private

In my case, I obtained:

/media/ubuntu/29b0ca4e-58f3-4802-9682-2a1aa42bb121/home/.ecryptfs/arcisd/.Private

Finally, I used the command "ecryptfs-mount-private" as follows:

sudo ecryptfs-mount-private /media/ubuntu/29b0ca4e-58f3-4802-9682-2a1aa42bb121/home/.ecryptfs/arcisd/.Private

I hope this is useful for someone more!

  • For future reference: you can copy from the terminal with ctrl+shift+c. – evilsoup Dec 12 '16 at 21:50
  • 1
    Please move your solution to an answer below. – Chai T. Rex Dec 13 '16 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.