2

I'm trying to build something from source using CMake that is intended for the current (16.04 - Xenial) build. It seems to depend on ECM which seems to be Extra CMake Modules (aka extra-cmake-modules on Xenial). It doesn't seem to be available for 14.04.

Any ideas how to get it, or instructions as to where I can download the source and build a package for Trusty, that I could install?

  • GAD3R has a great answer for building ECM from source, anyone care to hazard how to build it to a trusty compatible .deb package from source? – sibaz Dec 13 '16 at 11:37
4

Edit (Brought to top)

git clone git://anongit.kde.org/extra-cmake-modules
cd extra-cmake-modules
mkdir build
cd build
cmake .. # or run : cmake -DCMAKE_INSTALL_PREFIX=/usr .. &&
make
sudo make install

You can install the latest qt version as follows:

wget http://download.qt.io/official_releases/qt/5.7/5.7.0/qt-opensource-linux-x64-5.7.0.run
chmod +x qt-opensource-linux-x64-5.7.0.run
./qt-opensource-linux-x64-5.7.0.run

Original answer

The extra-cmake-modules is available on Ubuntu 16.04 , 16.10 and 17.04 version.

No summary available for extra-cmake-modules in ubuntu utopic.

You can install it on Ubuntu 14.04 but it is not recommended , it can break your System.

You can edit your /etc/apt/sources.list then add the following line:

deb http://cz.archive.ubuntu.com/ubuntu xenial main universe

Then update your system some dependencies will be upgraded

to install it run:

sudo apt install extra-cmake-modules
| improve this answer | |
  • 1
    As you say, simply pointing my sources at xenial, is a recipe for disaster. No, I want a safe way to install the library on trusty, either by package or source. – sibaz Dec 13 '16 at 10:50
  • Ok i will edit my answer – GAD3R Dec 13 '16 at 10:57
  • That's good, I'll try that now. Any idea how to make a package, so I can let dpkg manage it, rather than relying on make install? I think if I'm relying on make install then I'd rather it builds in /usr/local than clutter /usr – sibaz Dec 13 '16 at 11:26
  • Also FYI my company firewall doesn't allow SSH connections to the big bad world, so I had to use git clone anongit... – sibaz Dec 13 '16 at 11:28
  • And, kpmcore2.2 requires qt5.3 and so I'm back to square one. Thanks loads anyway, this definitely answered my question. Now how to get qt5.3 on trusty :-) – sibaz Dec 13 '16 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.