1

I have installed Eclipse Neon with C++ features on Ubuntu 16.04.

My problem is that some more unusual shortcuts do not work such as "copy lines" (ctrl+alt+down), or "move lines up" (alt+up), or autocomplete (ctrl+space) for example. The others more usual like "ctrl+c" or "ctrl+f" or "ctrl+z" do work.

I have tried to restart eclipse, and even the computer. I have restored the defaults key bindings but they do not work anymore. I think they worked just few times at the beginning after installing eclipse.

I don't want to uninstall and then reinstall eclipse because it is not a good solution if I have to do that every time, it will be just bothering at will. While searching for solutions on Google, it seems it is a quite recurrent issue for eclipse, but there is never real answers for them.

Thank you in advance

0

It looks like a bug has been reported relating to this issue here.

Reading through some of the comments, it sounds like it may be related to GTK3. One of the comments suggests running eclipse with GTK2 using the following:

SWT_GTK3=0 ./eclipse

This doesn't fix the issue but may give you a workaround until the bug has been fixed.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.