0

I have a triple-boot PC with Ubuntu 16.04, elementary OS Luna and WinXP with the first being the primary OS loaded upon startup. Everything worked very well. After running updates of eOS in the respective partition I ended up with i) GRUB starting eOS upon startup by default instead of Ubuntu and ii) about 8 entries for Ubuntu to choose from in the selection list of OSes available to start.

I know eOS Luna is a pretty old version, but for the moment I wanted to keep it.

Does anybody know i) what might be the reason for such effect and ii) how to fix it, i.e. make GRUB start U. by default and eliminate those extra entries?

Ulrich

0

Just boot to Ubuntu if you can and Update Grub

sudo update-grub

Reboot. This should correct the problem.

0

If you are able to boot to Ubuntu install and run "boot repair tool". If not possible to boot into Ubuntu,Create and boot to Ubuntu live disk and install and run boot repair tool. this should fix the issue.

0

I guess, you have Grub installed also in eOS but it's not erquired since it's installed in Ubuntu. I guess Boot partition (/boot) is shared, but you don't have shared custom config of Grub. If update of eOS executed update-grub, grub config was changed according to custom config located in /etc/default/grub of eOS.

Separate boot partitions

If boot partition is not shared, then boot flag was moved to eOS boot partition. Then the fix is easy. Open any partition manager (fdisk, gparted, gnome-disc-utilities, ...) and move boot flag to Ubuntu boot partition.

Shared boot partition

If boot partition is shared, then when you boot to Ubuntu and run sudo update-grub command, grub should be as earlier.

Alternativelly you can copy custom configs from Ubuntu to eOS or chroot from eOS to Ubuntu and run sudo update-grub command - it should have similar effect as booting to Ubuntu.

Another alternative is to remove Grub from eOS, but then you need to chroot to Ubuntu and run command sudo grub-install. Chroot can be executed from eOS or if you restart PC you would need live cd to do that.

Other

If previous tips didn't help, try to find solution in these links.

Article about installing/reinstalling/fixing problems/moving/... Grub is here

Article about configuring Grub is here

0

As said in another answer you can boot into Ubuntu and type:

sudo update-grub

However if Grub is on a different drive than sda it may not work and you will have to use:

sudo grub-install /dev/sda

In either case reboot to test changes.

0

thx to all of you for your advise and support. It is fixed now.

First: update-grub did not have any effect. I then started Ubuntu from a Live-CD, installed and started "boot repair" and ran the standard recovery. That took a while but then the system said that the boot sector would have been successfully recovered. But nothing had changed. Still the same effect with eOS being started by default and a whole bunch of nonsense entries in the selection list upon startup. I finally fixed it with boot repair / advanced options, where on one of the tabs the OS to start by default (if nothing else is selected) can be defined. Left everything else unchanged. Nevertheless this led to a complete reinstall of GRUB. That worked perfect. Great tool!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.