4

After buying and installing my new 4K monitor from Samsung, I noticed that the mouse pointer lags pretty badly on the screen even when there is nothing running on the computer except for the OS itself. I've tried downgrading the resolution from 3840x2160 to 2560x1440 and the problem goes away completely. I don't think the problem is my hardware as I'm running an i5-2310, an HD7870 and 6GB of RAM, I'd expect this configuration to at least be able to run the OS without a problem. I'm not sure though and would appreciate if anybody could tell me if the problem is really the hardware and, if not, how to solve it.

P.S. I'm running the monitor using an HDMI cable and enabling game mode on the monitor didn't help.

Update: The problem is probably the lack of proprietary drivers for my GPU on Ubuntu 16.04. I'll downgrade to Ubunntu 15.04 and install the drivers.

1

In my experience this occurs when some bus begins getting fully saturated / busy. I had some mouse and keyboard problems like this when I would run multiple USB devices on the same bus, such as cameras. When I had this problem I could run dmesg and see messages in the log explaining that USB data was being lost or the rates were being scaled down. Also take note that while it makes no sense in some ways for HDMI etc. to be interfering with USB they may be sharing some bus or module in hardware - even if you have a good CPU.

Assuming the bus being busy is the problem you could try a few things. The dumbest and easiest solution would be to simply unplug some devices that you don't need. For example, in my case I had web cameras plugged in that even if not being used would send USB data.

If you've played USB and PCI-E musical chairs as much as you can try taking hardware interface out of the equation and connecting via Teamviewer or some other synthetic test that doesn't involve any hardware. If that works then you know your bus is maxed out in some fashion, probably your motherboard needs to be replaced if that's the case or you need to find a different bus to somehow get input on - possibly bluetooth - but again how these all combine on your motherboard may produce the same limits.

Lastly you can try changing polling rates or refresh rates of devices that are using the same bus. This means essentially having a less responsive mouse or lower fps - both not amazing options if you want to keep the high resolution on the limited bus.

TL;DR - Run dmesg see what bus is being saturated

  • 1
    In spite of it being a real possibility, the problem was not a saturated USB bus. I tried disconnecting everything that was not necessary from my computer (4 devices in total) and the problem persisted. After thinking about the problem for a while I remembered that my GPU doesn't have drivers for Ubuntu 16.04 and that coupled with the 30fps limitation on the HDMI bus is most likely the cause for the lag on 4K. Thank you very much for your input though. I think I'll be downgrading to Ubuntu 15.04 and installing the GPU drivers. – João Victor Dec 12 '16 at 19:57
3

For anybody reading this with an Nvidia card, after my initial tests using the following hardware:

CPU: Intel 6700K
RAM: 64GB DDR4
VID: Nvidia 1080 GTX
SSD: 2x Samsung SSD 850 PRO 1TB (Raid 0)
TV: Samsung KS8500 4K
OS: Ubuntu 17.04 & 17.10

I had the same choppy lagging mouse movement. The solution was raising the refresh rate of the resolution. In my case it was in the Nvidia Settings. The video card had the Refresh Rate in AUTO (Which was setting it up as 30Hz). I changed it to 60Hz and that solved the issue.

enter image description here

The mouse now moves correctly and smooth.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.