2

I copied contents of my pendrive to a directory in mint machine. When I tried to click the copied contents through gui to view it said, "You do not have the permissions necessary to view the contents". In the other thread it was said that I can view my file by elevating privileges to the gui by gksudo command but do I have to do that everytime i copy a file from an external source. What can be done?. I need to differently copy or add permissions to the directory?. Please let me know.

1
  • Well i changed ownership of those areas using chown command, that solved it for me!
    – Nobody
    Dec 11 '16 at 19:44
6

Try using sudo chown yourUserName /path/to/folder this will give you ownership of the directory if it was for some reason mounted as root. If this still doesn't work try chmod +rwx /path/to/folder which will allow reading and writing to that directory

2
  • Yea yea I did that like I mentioned. It worked thanks anyway :)
    – Nobody
    Dec 11 '16 at 19:51
  • 1
    sudo chmod +rwx /var/www/html worked like a charm.
    – sandip
    Dec 23 '19 at 6:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.