0

I'm building an HTPC from an old desktop computer. My plan was to dual-boot LUBUNTU and openELEC. Being kind of new to Linux, I've been working over a week on this project and now I'm stuck. I've followed the instruction from http://wiki.openelec.tv/index.php/Dual_Boot (the 4.1 "old" section) to the letter. My Lubuntu worked very well, then install OpenELEC which also work very well, but my Grub interface is not showing up. Since I've install OpenELEC, I don't have access to Lubuntu anymore.

I've reinstall/repair grub with a live cd following: http://howtoubuntu.org/how-to-repair-restore-reinstall-grub-2-with-a-ubuntu-live-cd but it didn't help. I've look around online but most people having this problem are dual booting Windows, which I don't.

Here is some info:

Device     Boot     Start       End   Sectors   Size Id Type 
/dev/sda1 *         2048 293083135 293081088 139.8G 83 Linux 
/dev/sda2       293083136 298942463   5859328   2.8G 82 Linux swap / Solaris 
/dev/sda3       480204800 488396799   8192000   3.9G 83 Linux
/dev/sda4       298942464 480204799 181262336  86.4G 83 Linux

My Lubuntu is on sda1 and my OpenELEC System is on sda3. The 40_custom file:

#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.

menuentry "OpenELEC.tv" {
   set root=(hd0,3)
   linux /KERNEL boot=/dev/sda3 disk=/dev/sda4 quiet
}

menuentry "OpenELEC.tv (Textmode)" {
   set root=(hd0,3)
   linux /KERNEL boot=/dev/sda3 disk=/dev/sda4 textmode quiet
}

menuentry "OpenELEC.tv (Debugmode)" {
   set root=(hd0,3)
   linux /KERNEL boot=/dev/sda3 disk=/dev/sda4 debugging textmode quiet
}

And finally the default:

GRUB_DEFAULT="0"
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

FYI, I've started with GRUB_DEFAULT="OpenELEC.tv" but it wasn't working, I've put "0" with the hope it would boot Lubuntu by default at least.

I've also tried to boot with holding down shift but it didn't help.

Any idea what my next step could be? I'm stuck... Thanks

2

Try holding shift while booting up, this is the solution I see everywhere. OR if you don't care about data (or you could get a liveboot and copy files from your home directory to a thumb drive), just reinstall ubuntu beside WinXP and copy your /boot dir to a data disk in case this were to happen again, then you would have a quite handy liveboot disk and an extra /boot partition to copy/ use to fix broken files
good luck fixing your grub installation

  • I forgot to say in my post that I had also tried holding shift and it didn't work. For the thumb drive, my hardware doesn't support booting from it (it's quite old) and anyway, I don't use WinXP, it's only a OpenELEC-Ubuntu computer. – Bastien Dec 11 '16 at 19:21
  • then boot from a disk – pcs3rd Dec 12 '16 at 18:11
  • GRUB_DEFAULT="whatever lubuntu is" GRUB_HIDDEN_TIMEOUT=5 GRUB_HIDDEN_TIMEOUT_QUIET=false GRUB_TIMEOUT=10 GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" GRUB_CMDLINE_LINUX="" I am not responcable for any broken grub installs. I recomend you keep a backup of you config file for grub on a thumb drive and use a livecd to change the config file only after copying it. or use plop boot manager to boot from usb. last resort - install debian 8 or something. – pcs3rd Dec 12 '16 at 18:31
  • thanks @pcs3rd, it seems it was simply the GRUB_HIDDEN_TIMEOUT=0. Also, I've figure out the shift thing. It had to be hold during the bar blinking at the top left corner. I was holding it too early and not long enough. I'm sorry I can't vote your answer up, I'll come back when I'll get more reputation. – Bastien Dec 13 '16 at 2:06
  • your welcome, honestly, I thought it looked different than my config line when I was messing with boot perams and trying to basically break into it because I messed up the installer, my debian is usable and fully installed and able to be logged into. It also makes me very excited that I can do stuff now with my rep points – pcs3rd Dec 13 '16 at 2:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.