2

I'm currently under Ubuntu 16.04 and have installed the newest versions of Blender and Kdenlive from the official repositories.

Unfortunately, Blender won't let me select my GPU for rendering (Device is always set to "None"/CPU) and the GPU-Effects tab in the Kdenlive video editor is greyed-out.

The video card I am using is an AMD Radeon R7 360, so it is not very old and seems to work fine in GPU-heavy benchmark software (no display errors, temperature and usage graphs look normal).

Could there still be something wrong with my card, firmware or driver? How can I start to analyse what is going wrong or what can I do to solve this?

  • do have you added a ppa for blender? – Booming Jan 28 '18 at 0:30
1

Reading your situation I would assume that you only have the one graphics card in your system. You will need a 2nd capable card.

One to use for your main display AND another one for GPU Compute.(no display should be attached to the 2nd card.) once your system detects both cards you should be able to launch Blender and select the proper render option for the 2nd card.

As for KDENLive if it uses a 2nd GPU to compute you may have issues running both programs simultaneously ( I have not been able to test this out since the last build I tried basically locked up the program.) most NLEs (like LightWorks, and from what I seen with ShotCut) uses the GPU that also displays on your monitor so you may not need to worry much on that front...

Hope this steers you in the right direction.

  • Hi CJ Wilson, thank you for your suggestion. Yes, I only have one graphics card installed currently. I have never owned a computer with two GPUs installed simultaneously and I remember being able to select a graphics card for computing in Blender somehow, unfortunately I can't recall which one it was or how I was able to. That is an interesting observation, but I am currently unable to afford two graphics cards if one is merely used for display. Is there no way in Blender to make the display GPU available for computing? – Prototype700 Jan 13 '17 at 12:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.