I've installed bumblebee at my laptop due to the 520M GPU following the steps mentioned here.

What I see after logging out and in is this.

But I've noticed now that I do have some effects I didn't have, in example the windows open with a bounce effect (if we can call it that way) and the alt+tab feature shows now the screenshots of the windows.

What can I do?

Here's the link to pastebin with contents of xorg.0.log.

  • Could you post the contents of /var/log/Xorg.0.log on pastebin.com and put the link in your question? – Lekensteyn Dec 8 '11 at 22:38
  • @Lekensteyn: Added the link you've asked. So now, after following the guide I've mentioned at the comment below, only the intel gpu is used until I set a programme to run with nvidia by optirun program name? Should I use ironhide instead? or the new bumblebee project? Another thing is that I haven't used my cardon and cardoff calls. How can I find the correct calls for my gpu? – Chris Dec 9 '11 at 12:41
  • You've been playing with mj-casalogic/bumblebee before according to your other questions. Is this a fresh installation? mj-casalogic/bumblebee is crap, and Ironhide is just this old code with support for other Linux distributions removed. The Bumblebee-Project code is a rewritten version with better security compared to the old codebase (mj-casalogic/*). The ACPI calls are different for each laptop model (and sometimes even BIOS version). You haven't mentioned your model anywhere. As for your Unity issue, I really need to know whether it's a fresh installation or not. – Lekensteyn Dec 9 '11 at 17:40
  • If possible, generate a bugreport using sudo bumblebee-bugreport and mail it to bumblebee@lists.launchpad.net (if you've a LP account) or me lekensteyn@gmail.com. – Lekensteyn Dec 9 '11 at 17:41
  • @Lekensteyn: When you say "this", to what you are referring? If you are referring to the installation of ubuntu, yes it's a new one(formatted the old partition and installed ubuntu 11.10). My gpu is nvidia gt 520M (I have mentioned it above). If you mean my laptop's model is ASUS X53S with an i5 2410M cpu, 4GB RAM. I generated a bug report and sent it to your gmail account. – Chris Dec 11 '11 at 19:19

I see that optirun does not work for you. The Troubleshooting article mentions a solution for an error in your /var/log/Xorg.8.log: edit /etc/bumblebee/xorg.conf.nvidia and change DFP to CRT-0.

I've downloaded the acpidump for your laptop model and it looks like that the calls in /etc/bumblebee/cardo{n,ff} are correct. To get PM really working, you also need the acpi_call kernel module. You can install it by installing acpi-call-tools from the bumblebee/stable PPA (which you've already enabled):

sudo apt-get install acpi-call-tools

In /etc/bumblebee/bumblebee.conf, change STOP_SERVICE_ON_EXIT=Y to STOP_SERVICE_ON_EXIT=N to allow the card to be disabled after the last optirun instance has been quit. You need to restart the daemon after that change:

sudo /etc/init.d/bumblebee restart
  • Sorry for the delayed reply. I just did what you've said. Now, how can we confirm that optirun works and everything is working fine? Also, how could I check the list of programs I have set to run with optirun? And maybe edit it(remove any program)? – Chris Dec 15 '11 at 23:47
  • Currently you need to start programs manually with optirun. – Lekensteyn Dec 16 '11 at 12:10
  • If I type optirun firefox, won't firefox run everytime with the nvidia card? – Chris Dec 16 '11 at 15:15
  • No, only that time. – Lekensteyn Dec 16 '11 at 15:27
  • Is this going to be added as a feature on new releases? Also, which applications do you recommend running with optirun? – Chris Dec 16 '11 at 15:31

You can try to reset the unity settings by opening a terminal and running unity --reset. If the driver from bublebee doesn't support Unity, then you can use Unity 2D by clicking the button next to the password field before you log in.

  • I tried this guide as well ivegotavirus.com/blog/2011/11/06/… and after setting it up I logged out and used the unity --reset command and now it works fine. How can I be sure that everything is working fine? – Chris Dec 7 '11 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.