0

I have a DELL XPS-13-9350

Every time my laptop was connected to a wifi. And i connect it to a wired connection. The system freezes, the screen does not update anymore. And keyboard or mouse do not work anymore. After a reboot the wired connection works fine.

I have updated to the newest kernel:

$ uname -r
4.8.12-040812-generic

But the issue is still the same.

Here some info of the Ethernet interface:

  *-network
   description: Ethernet interface
   physical id: 2
   logical name: enx00e04c6802d1
   serial: 00:e0:4c:68:02:d1
   size: 100Mbit/s
   capacity: 1Gbit/s
   capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8152 driverversion=v1.08.6 duplex=full ip=192.168.178.45 link=yes multicast=yes port=MII speed=100Mbit/s

Do i need to provide more information? Any help would be much appreciated.

0

A bios update did the trick. Every runs smooth after that.

Edit: I installed: XPS_9350_1.4.10.exe. I'm not sure what my previous version was. But it came with the xps 9350 when i got it in november 2015.

Thx for the tips, Elder Geek.

  • Expanding this answer to include the BIOS versions you updated from and to would make this answer useful. – Elder Geek Dec 20 '16 at 20:47
  • I installed: XPS_9350_1.4.10.exe now. I see there is even a newer version available: XPS_9350_1.4.12.exe. I'm not sure what my previous version was. But came with the xps 9350 when i got it in november 2015. – Barry Jan 7 '17 at 15:27
  • You might edit that valuable information into your post as comments can be deleted for numerous reasons here and it would be unfortunate if it was lost. – Elder Geek Jan 7 '17 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.