2

How can I install libboost1.59 ?

I have tried many methods to install it, but fail to update the version 1.58 on my Ubuntu 16.04 to the version 1.59.

I tried this and this on StackOverflow, this on linuxfromscratch.org and this blog post

Who can give me an effective method?

  • Did you try the get the boost version you want example ? – George Udosen Dec 11 '16 at 3:58
  • I take it that upgrading to 16.10 is not an option? – fkraiem Dec 11 '16 at 7:22
3

To get the latest go here, then:

  1. download and extract with tar -xf boost_X_XX_X.tar.gz where XX is the version number, like tar -xf boost_1_62_0.tar.gz
  2. cd boost_X_XX_X
  3. get required libraries:

    sudo apt-get update && sudo apt-get install build-essential g++ python-dev autotools-dev libicu-dev build-essential libbz2-dev libboost-all-dev
    
  4. build with ./bootstrap.sh --prefix=/usr/local

  5. install with sudo ./b2 install

Please note you can also get the version currently on your version of Ubuntu can be gotten here

  • Thanks, I tried this method, it will install the version1.58 in required libraries libboost-all-dev, The libboost 1.58 comes with Ubuntu 16.04 system, so I re-build a ubuntu 16.10 version. Thanks for you help – Gao Yuze Dec 12 '16 at 1:17
  • It seems that sudo apt-get install libboost-all-dev still installs the most recent version of boost for the current Ubuntu version (boost 1.54 for Ubuntu 14.04), while the whole purpose of the above instruction is to install a newer version... How do I overcome this? – Sergei Tikhomirov Mar 11 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.