0

I have been looking at questions about Ubuntu 16.04 LTS running too slow. I have concluded that all those asked questions were either having too old PCs or Laptops or Nvidia graphics.

I have a fairly high spec configuration:-
6 GB RAM, Core i3 (2nd gen), SSD 256GB + 1TB HDD

The issue is very serious when I start playing video in chrome of even Firefox for that matter. There were answers saying tweak with your Chrome settings Andersen I even did that but the issue persists. Sometimes the system hangs everything and I can see chrome/firefox consuming 100% CPU. Things used to work really well until 14.04 LTS. I can see a lot of graphics improvement in 16.04 LTS but that has made usage of Laptop quite impossible.

Here are my graphics details in case they can help answering this question.

 *-display               
       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:29 memory:dd000000-dd3fffff memory:c0000000-cfffffff ioport:e000(size=64  
1
0

Why don't you try out Compiz Config Settings Manager and dial back some of the Unity graphic embellishments by enabling Low Graphics Mode.

In terminal, type:

sudo apt-get update

sudo apt-get install compizconfig-settings-manager

In CCSM, go to the Desktop section and select Ubuntu Unity Plugin. Look at the very bottom and you'll see Enable Low Graphics Mode. Check it.

See if that improves the feel a bit.

enter image description here

8
  • ..continued But I already tried doing that before posting the question but that did not help . Not sure what is the is issue that consumes that much of CPU. – Chand Prakash Dec 24 '16 at 21:29
  • How much swap space do you have set up? What is the terminal output of free -h after the system has been running for a while? – heynnema Dec 24 '16 at 22:16
  • The issues is even that is not bottleneck – Chand Prakash Dec 26 '16 at 1:39
  • Below is output of (free -h) total used free shared buff/cache available Mem: 5.7G 2.2G 928M 466M 2.6G 2.8G Swap: 5.9G 0B 5.9G and I believe that's quite good. – Chand Prakash Dec 26 '16 at 1:40
  • Free -h looks fine. Log out of your current login, and log into the Guest account, and see if you have the same problem. – heynnema Dec 26 '16 at 1:53
0

Even on a power machine, I tend to use low graphic mode. Also turn off setting (in apps) that provide transparent background or alike. It makes a huge difference. I used to use Terminator with a cool looking 10% opacity just to learn that my Cpu was churning away.

Last but not least, and not to start a flame wars, but Unity desktop is not exactly know to be "lightweight". Look to use something like xcfe or even i3wm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.