I have a laptop with a pre-installed Windows 10. I wanted to switch to ubuntu, but I decided to leave windows installed in case ubuntu's installation doesn't work. So I created a new partition and installed ubuntu 16 LTS on it in uefi mode, using a live USB made by Rufus. Ubuntu was installed successfully and restarted. But Windows quickly loaded as if nothing happened. And I can't access Ubuntu. Even by holding Shift+Restart and chosing Ubuntu.

I tried every solution I found especially those mentionned in :



I used the command bcdedit to set the path to ubuntu


Windows Boot Manager
identifier              {bootmgr}
device                  partition=\Device\HarddiskVolume2
path                    \EFI\ubuntu\shimx64.efi
description             Windows Boot Manager
locale                  en-GB
inherit                 {globalsettings}
default                 {current}
resumeobject            {11e89e34-0792-11e6-bec9-91b447580268}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 30

Windows Boot Loader
identifier              {current}
device                  partition=C:
path                    \WINDOWS\system32\winload.efi
description             Windows 10
locale                  en-GB
inherit                 {bootloadersettings}
recoverysequence        {11e89e36-0792-11e6-bec9-91b447580268}
recoveryenabled         Yes
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \WINDOWS
resumeobject            {11e89e34-0792-11e6-bec9-91b447580268}
nx                      OptIn
bootmenupolicy          Standard

I started Live CD version of ubuntu to copy shimx64.efi to /EFI/Boot and /EFI/Microsoft/Boot and renamed it to Bootx64.efi and Bootmgfw.efi using a Terminal. And when I restarted, nothing happened and I got this error :

Insert system disk in drive,
Press any key when ready....

Then I restored back the boot files, and retried with Boot-Repair's recommended repair. Restarted, and I got the same previous error...

I also can't choose ubuntu to boot first from Uefi boot in bios setting, as I find only HDD/SSD, USB memory, ODD, LAN1, LAN2 .... Same when executing the command efibootmgr .

Please help me. I wasted an entire day trying differents solutions as nothing seem to work out for me.

Computer infos:

Toshiba Portege R930 series
Os : Windows 10
UEFI boot with secure boot
Intel Rapid Start
SSD 256 Go

Among many solutions this is the solution that worked for me :

  • Start LiveCD Ubuntu
  • Open a new terminal and download Boot-Repair.
  • Start Boot-Repair > Advanced Options > Uncheck "Secure boot" in Grub Options > start the repair.
  • Reboot PC > access Bios setting > deactivate Secure boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.