I ran into a weird problem. I put some env variables into .bashrc and it works as it should:


But the env variable is not accessible when executing bash scripts. Suppose I create /tmp/sample.sh with below content:

#! /bin/bash

When I run above script, echoes an empty line:

  • 2
    Can you show the relevant part of your .bashrc? My guess is you're not exporting: export HADOOP_HOME=/home/me/dist/hadoop, when you run /tmpsample.sh` (which spawns a new bash with a new environment) HADOOP_HOME isn't in the new environment.
    – John N
    Dec 10, 2016 at 13:54

1 Answer 1


That's because the HADOOP_HOME variable isn't exported:

$ cat foo.sh

$ HADOOP_HOME=/home/me/dist/hadoop

$ foo.sh

$ export HADOOP_HOME
$ foo.sh
HADOOP_HOME: /home/me/dist/hadoop

When you run a shell script, that script will run in its own bash instance (that's what the #!/bin/bash does) that is a child shell of the current one. Variables are not passed to child shells by default, only if they are exported. Think of each bash session as independent (they largely are). You usually don't want variables defined in one to pollute the environment of another. For those cases where that is necessary, use export.

  • 1
    Not working under Ubuntu 21.04 :-/ Bash 5.1.4: BAR=' yes', echo $BAR (fine), export BAR, howdy.sh (has echo "BAR: $BAR" only outputs “BAR: ”
    – Frank N
    Jul 12, 2021 at 14:13
  • 1
    @FrankNocke please open a new question where you can show all relevant details. This isn't something that will be affected by bash version, really, so my guess is you are launching the script from a different session, but if you open a new question and explain exactly what you're doing, we should be able to figure it out.
    – terdon
    Jul 12, 2021 at 14:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .