2

Your help would be very much appreciated!

I have 20+ years programming experience but I'm not a real Linux expert. I am trying to remote desktop from Ubuntu (16.04) to Lubuntu (16.04) using vino-server (the Ubuntu default).

The remote server is on Google compute engine. I can successfully SSH into the remote machine.

I have spent approximately 60 hours over the last 10 days (outside of work) trying to accomplish this; but, I have not been successful and for the first time I'm approaching a forum. I have (unsuccessfully) tried so very many permutations that I'm not sure where to start.

I've tried many variations on ssh (-X, -Y, -L), xhost +, export DISPLAY, etc. At best I can remote via remmina but strangely it shows my client desktop. Perhaps someone could kindly point me to a solution that explicitly spells out the command line steps required to launch Lubuntu remotely (for 16.04).

I'm using Remmina/VNC as the client. If I apply suggested steps and they fail to work (for me) then I'll respond with the specific command line output.

Thank you for taking the time to help me in this matter. I don't normally give up but in this case I need some help from those wiser Linux community.

0

In case it's of any help:

I gave up trying to use vino and resolved via the following solution. In this instance I had Ubuntu 16.10 installed on the (google compute engine) server. The client machine I'm connecting from has the standard Ubuntu 16.04 desktop installed.

From my client machine:

ssh myusername@myserverIPaddress

On remote server:

sudo apt-get update
sudo apt-get install lubuntu-desktop
sudo apt-get install vnc4server
vncserver :0
vncserver -kill :0

Then I modified contents of "~/.vnc/xstartup" to:

#!/bin/sh
xrdb $HOME/.Xresources
/etc/X11/Xsession
autocutsel -fork
/usr/bin/lxsession -s Lubuntu -e LXDE &

Then I restarted the vncserver (changing the display to fit my screen):

vncserver -geometry 1920x1200 -depth 24 :0

Then from my client machine (using Remmina Desktop Client) I configured:

On the "Basic" tab I set: Protocol = VNC, Server = myserverIPaddress:5900, Username = myusername. On the "ssh" I enabled ssh tunnelling through port 22 and pointed the "Identity file" to my private key file in "~/.ssh" folder.

I saved the Remmina entry and then double clicked the entry in the Remmina Desktop Client window and after entering ssh password (a popup) and subsequently the prompted vnc password I connected to Lubuntu on the remote server. I ought to have mentioned, when you run "vncserver :0" above (for the first time) it will prompt you to enter a vnc password.

| improve this answer | |
0

To answer your question about vino and remmina, there is one gotcha with vino:

Vino asks you, on the server system (i.e. the remote server in your case) whether you want to indeed share your screen. You have to click on that button...

Yeah, exactly!


So that won't work as is.

First, you log in with ssh:

ssh remote-box

Then you start vino like so:

systemctl --user start vino

If you are not auto-logged in, you'll want to make changes to get that to work because I don't think vino works unless you are logged in.

At this point you can connect with remmina assuming you have no firewall blocking port 5900. Start remmina, enter your remote computer IP address (or a domain name if you have one) and make sure to select VNC. Then it will connect. However, at that point the screen is black... because you did not authorize the connection.

So, to authorize, you want to first stop the server:

systemctl --user stop vino

Then change the prompt settings:

$ gsettings get org.gnome.Vino prompt-enabled
true
$ gsettings set org.gnome.Vino prompt-enabled false
$ gsettings get org.gnome.Vino prompt-enabled
false

Now restart the vino server and try to connect with remmina. It's going to show you the desktop this time.

WARNING: It is not clear to me, but it looks like the data on the connection is secure (encrypted) but the port will accept anyone--no login/password required. So unless you have a static IP address and only allow that IP to connect to 5900 in your firewall, it's not recommended to turn off the prompt in this way.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.