0

My laptop is 2GB, 1.2GHz dual core, LUKS. I installed Ubuntu in place of Windows XP and I thought it would go faster, but it's dog slow. This is what I have to live with:

xload

  • 1
    Xubuntu is a better choice for low end hardware. Generally, keep in mind that Windows XP is an OS from 2001. – mikewhatever Dec 9 '16 at 19:59
  • Really? What does Ubuntu have that Xubuntu doesn't? I'd like to print and connect my iPhone and use Bluetooth (but Ubuntu bluetooth is broken anyways). – Chloe Dec 9 '16 at 20:03
  • It could be media scanner 2.0 – userDepth Dec 9 '16 at 20:06
  • Well, it's actually easy to look up, read a review of something. The two have the same underlying system, but different DEs - Desktop Environments. – mikewhatever Dec 9 '16 at 20:12
  • @Chloe there is Lubuntu. I have it on a machine with half of yours parameters and it works good. It gives me much better performance than WinXP. – pa4080 Dec 9 '16 at 22:07
5

First step: Decrease swap use. This is specially useful fow low RAM (2GB or less) systems. You can check swap use by this command:

cat /proc/sys/vm/swappiness

This is generally set to 60. To change the swappiness into a more sensible setting, type in the terminal

sudo nano /etc/sysctl.d/99-sysctl.conf

At the end of this file, append the following line.

vm.swappiness=10

Disable Unneeded Startup Applications.

enter image description here

launch startup application by typing startup in dash and to disable a startup application, simply uncheck it.

Disable Fancy Effects Use compizconfig-settings-manager to disable them

enter image description here

Install using

 sudo apt install compizconfig-settings-manager

and disable unwanted effects

Install preload

sudo apt install preload

This software memorize what applications you use most often and preload related libraries and binaries into memory so these applications can be launched faster.

| improve this answer | |
  • Do I have to restart for vm.swappiness to take effect, or restart a service? I only had 3 startup items, Gnome, Indicator Application, and SSH cache. I also disabled Alt-Tab for Unity and enabled Static Application Switcher - much faster! I currently have Unity plugin disabled and it seems quite fast, but no task bar, window borders, or even menu bars so I guess I have to re-enable that. Neat! – Chloe Dec 9 '16 at 21:27
  • @Chloe Yes you have to restart for vm.swappiness and also you can uncheck Gnome and SSH cache. If disabling unity plugin causing some problem then re-enable it. – Rahul Dec 9 '16 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.