-1

I'm working from a cafe, and I'm thinking there's a firewall on the router preventing me from using the command ssh 'ip address'. Is there exists a way to bypass the firewall such as I can access the remote machine?

P.S. I want to access the remote machine via a local network.

closed as off-topic by Kaz Wolfe, David Foerster, Zanna, Eric Carvalho, TheWanderer Dec 10 '16 at 21:52

  • This question does not appear to be about Ubuntu within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 5
    I'm voting to close this question as off-topic because this is a question about a router/firewall instead of Ubuntu. You could try asking in Super User or Server Fault for help with this particular issue. – Kaz Wolfe Dec 9 '16 at 18:38
  • The 16.10 tag is irrelevant to this question. Please only use version tags for questions that are actually restricted to that particular version. – Kaz Wolfe Dec 9 '16 at 18:50
  • It is not uncommon for businesses routers to block outgoing packets to port 22 (SSH). I would suggest you try changing the SSH port on the remote machine to something other than port 22, and then see if that works. – Doug Smythies Dec 9 '16 at 19:24
  • I'll try to change port. Do I need to change port on both machine? – Sandra Ross Dec 9 '16 at 19:25
  • 1
    Yes. Say, for example you changed sshd on the remote server to listen on port 2222, then your client command would become ssh -p 2222 ip_address (check man ssh) – Doug Smythies Dec 9 '16 at 20:11
1

I understand that you want to access a remote machine on another location through the internet and not through a local connection. If this is the case, you have to access the router's settings and open the port the ssh server is using for incoming connections. There is no other way to bypass a closed port.

  • Is there a way to verify if the port is indeed close? In fact, I want to access the remote machine through a local connection. – Sandra Ross Dec 9 '16 at 19:00
  • The router firewall should not block local network connections unless access has been denied to certain computers using the mac address filter for example. Those computers wouldn't be able to access the internet either though. If you are trying to connect using the correct ssh port, then something else causes this issue probably. You have to make sure the default port 22 hasn't been changed in the server's settings and that the server machine doesn't block that port using a software firewall, like ufw for example. – Stormlord Dec 9 '16 at 19:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.