2

I'm running a new install of Ubuntu 14.04 and my firefox crashes immediately upon starting up. Here is the error message I get in the terminal:

(firefox:6660): GLib-GObject-CRITICAL **: g_object_ref: assertion 'object->ref_count > 0' failed

(firefox:6660): GLib-GObject-CRITICAL **: g_object_unref: assertion 'object->ref_count > 0' failed

(firefox:6660): GLib-GObject-CRITICAL **: g_object_ref: assertion 'object->ref_count > 0' failed

(firefox:6660): GLib-GObject-CRITICAL **: g_object_unref: assertion 'object->ref_count > 0' failed
ExceptionHandler::GenerateDump cloned child 6704
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
Bus error (core dumped)

I've tried purging and reinstalling firefox with apt-get but it didn't help. I also get a crash reporter, here are the contents of it:

Add-ons: ubufox%40ubuntu.com:3.2,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:50.0.2,aushelper%40mozilla.org:1.0,webcompat%40mozilla.org:1.0,firefox%40getpocket.com:1.0.5,e10srollout%40mozilla.org:1.5,langpack-en-GB%40firefox.mozilla.org:50.0.2,langpack-en-ZA%40firefox.mozilla.org:50.0.2
AddonsShouldHaveBlockedE10s: 1
BuildID: 20161130094553
ContentSandboxCapabilities: 117
CrashTime: 1481203588
E10SCohort: disqualified-test
EMCheckCompatibility: true
FramePoisonBase: 7ffffffff0dea000
FramePoisonSize: 4096
InstallTime: 1481203057
Notes: OpenGL: Intel Open Source Technology Center -- Mesa DRI Intel(R) Kabylake GT2  -- 3.0 Mesa 11.2.0 -- texture_from_pixmap
FP(D000-L10000-W00000000-T0000) 
ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
ProductName: Firefox
ReleaseChannel: release
SafeMode: 0
SecondsSinceLastCrash: 77
StartupTime: 1481203587
TelemetryEnvironment: {"build":{"applicationId":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","applicationName":"Firefox","architecture":"x86-64","buildId":"20161130094553","version":"50.0.2","vendor":"Mozilla","platformVersion":"50.0.2","xpcomAbi":"x86_64-gcc3","hotfixVersion":null},"partner":{"distributionId":null,"distributionVersion":null,"partnerId":null,"distributor":null,"distributorChannel":null,"partnerNames":[]},"system":{"memoryMB":15926,"virtualMaxMB":null,"cpu":{"count":4,"cores":2,"vendor":"GenuineIntel","family":6,"model":142,"stepping":9,"l2cacheKB":256,"l3cacheKB":4096,"speedMHz":2701,"extensions":["hasMMX","hasSSE","hasSSE2","hasSSE3","hasSSSE3","hasSSE4_1","hasSSE4_2","hasAVX","hasAVX2"]},"os":{"name":"Linux","version":"4.4.0-53-generic","locale":"en-US"},"hdd":{"profile":{"model":null,"revision":null},"binary":{"model":null,"revision":null},"system":{"model":null,"revision":null}},"gfx":{"D2DEnabled":null,"DWriteEnabled":null,"adapters":[{"description":"Intel Open Source Technology Center -- Mesa DRI Intel(R) Kabylake GT2 ","vendorID":"Intel Open Source Technology Center","deviceID":"Mesa DRI Intel(R) Kabylake GT2 ","subsysID":null,"RAM":null,"driver":null,"driverVersion":"3.0 Mesa 11.2.0","driverDate":null,"GPUActive":true}],"monitors":[],"features":{"compositor":"none"}}},"settings":{"blocklistEnabled":true,"e10sEnabled":false,"e10sCohort":"disqualified-test","telemetryEnabled":false,"locale":"en-US","update":{"channel":"release","enabled":true,"autoDownload":true},"userPrefs":{"browser.newtabpage.enhanced":true},"addonCompatibilityCheckEnabled":true,"isDefaultBrowser":false},"profile":{}}
Theme: classic/1.0
Throttleable: 1
UptimeTS: .6687318
Vendor: Mozilla
Version: 50.0.2
useragent_locale: en-US

This report also contains technical information about the state of the application when it crashed.

Anyone have any idea what could be causing this and how to fix it?

1

In case someone wants the fix for this same error, it got resolved when I upgraded my kernel to 4.8.14

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.