0

I get continuous errors when installing behind a proxy. I have the model-config and model-default set with proxy and no-proxy settings. Eventually, during openstack install, I run into a continuous set of error messages from the debug log like

juju.apiserver.client error fetching public address: no public address.

I deleted and reinstalled the controller but I keep hitting a loop (seen via status) of ceph, neutron and ntp failing over and over to install.

I read something about this being fixed in 2.0 with "spaces" but it does not say what is needed for the spaces. Right now, stack install just keeps trying to install and never stops. From the proxy log, it eventually switches over to IPV6 for some reason.

1
  • please paste the various error messages you got in your post. – George Udosen Dec 9 '16 at 4:36
0

What is the exact command you used that is related to the errors? Also, what is the exact command used for creating the controller?

0
juju bootstrap --config http-proxy=$http_proxy --config https-proxy=$https_proxy --config no-proxy=$no_proxy prodmaas prodmaas-controller

juju install openstack-base

The errors come from watching the debug during the install. Maybe those are nothing but in the end, from juju status I get that neutron has errored out. And then it begins a constant cycle of retries with the rest of Openstack waiting on it. I have deployed via the GUI as well with the same result.

0

I found that in the Neutron charm, the config.yaml has "git://" monikers instead of "http://" or "https://" monikers. These are not passing my proxy. I've opened a bug against the charm as I do not believe that 'git://' will pass a proxy without configuring git to allow it or by configuring git to translate it in the library.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.