1

I have tried all solution advices on askubuntu platform. But no way to solve that login loop issue.

When I select the latest Nvidia proprietary tested driver (nvidia-367) , ubuntu stucks on login loop.

Also I tried to erase all disk and reinstall ubuntu but no way to solve that issue.

By the way it occured after an software updater alert and I didn't read it and just accepted(that was different than software updater i think it was about drivers).

So what can be the main problem and why erase all disk and reinstall ubuntu couldn't work ?

  • What happen when you choose another Nvidia driver, I mean, not the latest but an older driver, does it work? – David Tabernero M. Dec 11 '16 at 23:21
  • @Davdriver No I choose nvidia-364 also it does same thing. I can log in with selecting nouveau driver but i don't want to use that driver because of its performance. – user1136403 Dec 12 '16 at 11:17
  • my crystal ball isn't working today , please could describe your hardware – Amias Dec 15 '16 at 12:39
  • @DavidFoerster Thanks, By the way i solved keyboard problem , just login loop continues. I split that question with one problem. – user1136403 Dec 15 '16 at 15:21
  • @Amias I use dell-7537 with Nvidia GT 750m graphic card. – user1136403 Dec 15 '16 at 15:25
1

i used to have the 7737 version of that laptop but i don't remember using 14.04 on the bare metal with that one, it was 16.04 mostly and maybe 15.10.

If you don't have a specific reason to be stuck on 14.04 then i would recommend upgrading to at least 16.04 as there are many worthwhile improvements in hardware support for that laptop.

Make sure you have the graphics drivers ppa setup , you should use the drivers nvidia-304

To do that just run this

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-304 nvidia-prime
sudo reboot  

That version is correct at the time of writing, if anyone is reading this later they should check the recommendation on this page https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

  • Is there a special reason why you recommend to install these legacy drivers for very, very old NVIDIA GPUs ? Those drivers 304 are available from the official repositories, so when adding the PPA should make sense at all, it would be a good idea to recommend installing the latest official stable drivers 375.26 from the NVIDIA long-lived branch, which are supporting modern NVIDIA graphics adapters up to NVIDIA GEFORCE 10 series. – cl-netbox Dec 15 '16 at 17:28
  • thats what the ppa recommends , see the link. or maybe i mismatched the version. Not all versions of the nvidia driver work with optimus. – Amias Dec 16 '16 at 18:10
  • @Amias I tried this solution (used nvidia-375), it seems ok but it's not proprietary driver , right? – user1136403 Dec 19 '16 at 7:53
  • Those are the nvidia proprietary drivers but packaged by Ubuntu volunteers. Its also worth trying newer kernels, 4.7 fixes a lot of primus issues – Amias Dec 19 '16 at 12:23
0

Go to TTY and try this (replace-user_name with your user name):

sudo mv /home/user_name/Xauthority /home/user_name/Xauthority.back

If it didn't work check if permissions and execution mode is correct.

  • As I said in my questions, I tried all solutions(firstly tried Xauthority permissions) but no way and lastly erased disk and reinstalled ubuntu. – user1136403 Dec 8 '16 at 21:20
  • If as you said, you tried all solutions on Ask Ubuntu, state and link those solutions tried in your question so that other users don't spend their time trying to help you with something you already did and did not work :) – M. Becerra Dec 15 '16 at 23:04
0

the reason why you can't "restore" back to a working status even without a full re-installation is because it's a combination problem between your hardware and a software update...so, there are two solutions:

  • go back manually to a software state prior you update and then never update your software
  • update to latest ubuntu version

the second one is the best

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.