1

I can't find a way to decrease the sensitivity of the touchpad on my HP spectre laptop running ubuntu 16.10. Changing the settings in the built-in "mouse and touchpad" settings doesn't work at all - literally nothing happens when I change any setting under either mouse or touchpad.

I did some research and found out that I might need to adjust x.org settings just to change the touchpad settings (which seems absolutely ridiculous, btw, but whatever). So, I tried to learn about xinput.. but all the guides mention settings I can't find.. namely ones related to sensitivity or pointer speed.

For reference, here is the output of xinput --watch-props for my touchpad:

$ xinput --watch-props 15
Device 'SynPS/2 Synaptics TouchPad':
Device Enabled (139):   1
Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Tapping Enabled (279): 1
libinput Tapping Enabled Default (280): 0
libinput Tapping Drag Enabled (281):    1
libinput Tapping Drag Enabled Default (282):    1
libinput Tapping Drag Lock Enabled (283):   0
libinput Tapping Drag Lock Enabled Default (284):   0
libinput Accel Speed (285): 1.000000
libinput Accel Speed Default (286): 0.000000
libinput Natural Scrolling Enabled (287):   0
libinput Natural Scrolling Enabled Default (288):   0
libinput Send Events Modes Available (259): 1, 1
libinput Send Events Mode Enabled (260):    0, 0
libinput Send Events Mode Enabled Default (261):    0, 0
libinput Left Handed Enabled (289): 0
libinput Left Handed Enabled Default (290): 0
libinput Scroll Methods Available (291):    1, 1, 0
libinput Scroll Method Enabled (292):   1, 0, 0
libinput Scroll Method Enabled Default (293):   1, 0, 0
libinput Click Methods Available (294): 1, 1
libinput Click Method Enabled (295):    1, 0
libinput Click Method Enabled Default (296):    1, 0
libinput Middle Emulation Enabled (297):    1
libinput Middle Emulation Enabled Default (298):    0
libinput Disable While Typing Enabled (299):    1
libinput Disable While Typing Enabled Default (300):    1
Device Node (262):  "/dev/input/event6"
Device Product ID (263):    2, 7
libinput Drag Lock Buttons (301):   <no items>
libinput Horizonal Scroll Enabled (264):    1

Am I destined to just have a horrible touchpad experience in ubuntu on this laptop? For whatever it's worth, the touchpad is so sensitive a tiny movement of less than an inch can move the cursor across the whole screen.

Here's the output of xset -q:

$ xset q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
03: Compose:     off    04: Kana:        off    05: Sleep:       off
06: Suspend:     off    07: Mute:        off    08: Misc:        off
09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
12: Group 2:     off    13: Mouse Keys:  off
auto repeat delay:  500    repeat rate:  33
auto repeating keys:  00ffffffdffffbbf
                    fadfffefffedffff
                    9fffffffffffffff
                    fff7ffffffffffff
bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  1/1    threshold:  6
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,built-ins
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On
  • Have you tried messing with libinput Accel Speed, or tried using xset? – negusp Dec 8 '16 at 17:37
  • Yes, accel speed set to 0 is about as low as I can get it, but it's still way too fast. Not sure what I should / would do with xset. – tamale Dec 8 '16 at 18:39
  • Now, try the command xset m 3/2 0 and see if there's a difference. – negusp Dec 8 '16 at 22:41
  • Nope, no change. – tamale Dec 9 '16 at 17:00
  • Let us continue this discussion in chat. – tamale Dec 9 '16 at 18:15
0

for my Spectre 13 the following settings made the touchpad usable:

xinput set-prop 10 'Synaptics Off' 0
xinput set-prop 10 "Synaptics Finger" 50 50 255
xinput set-prop 10 "Synaptics Noise Cancellation" 40 40
xinput set-prop 10 "Synaptics Palm Detection" 1
xinput set-prop 10 "Synaptics Gestures" 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.