I am having this issue with 11.10 . Ubiquity doesn't detect the existing windows 7 partition and when I choose to manually partition the disk, I can't see any partition there. When I log into the live system and open Disk Utility, It shows my HDD partitions fine but Ubiquity for some reason is unable to detect them. Can't install 11.10 'cause of this issue :( I tried installing 12.04 Alpha 1 and the issue still persists.

There's already a bug [Link: http://pad.lv/798285 ] report regarding the issue but it seems that the report has gone unnoticed.

Is there any way I can still be able to install Ubuntu on this system.


Here's the output of sudo fdisk -lu

ubuntu@ubuntu:~$ sudo fdisk -lu

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x66daaff3

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   212994047   106496000    7  HPFS/NTFS/exFAT

Disk /dev/sdb: 988 MB, 988282880 bytes
31 heads, 61 sectors/track, 1020 cylinders, total 1930240 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000d3ee9

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          61     1928819      964379+   c  W95 FAT32 (LBA)

Screenshot: Disk Utility can detect the NTFS partition but ubiquity doesn't.

enter image description here

  • This is usually due to a corrupted partition table. Edit your question and add the output of sudo fdisk -lu – psusi Dec 7 '11 at 14:59
  • @psusi I've updated the question with the output and a screenshot. – Gaurav Butola Dec 8 '11 at 11:05
  • could you please post some info related to 'gdisk'... is it for windows or linux.. how can I use it for solving the same issue?? Thanks in advance.. I'm newbie... – user42422 Jan 17 '12 at 22:02
  • @Roy It is available for Windows and Linux sourceforge.net/projects/gptfdisk I tried to solve the problem from windows but couldn'g get it to work. Then I used ubuntu live cd and installed gdisk from the software centre. There was a GPT partition that I had to remove using gdisk and it worked after that. – Gaurav Butola Jan 18 '12 at 9:11
  • Can you explain how u solved the problem with gdisk !! ? – user68411 Jun 5 '12 at 0:47

It looks like this disk used to use GPT, but then you used a non GPT aware tool to redo the msdos partition table, so now the system isn't sure which partition table it should be using. You will need to remove the broken GPT to properly go back to using the msdos table, which you can do with the gdisk utility.

| improve this answer | |
  • 2
    Could you tell me how to do that? I've downloaded gdisk but don't know how to use it. – Gaurav Butola Dec 8 '11 at 18:04
  • Thanks so much, I have finally solved the problem using gdisk. Finally I'm able to install Ubuntu on my laptop :D Thanks again. – Gaurav Butola Dec 8 '11 at 18:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.