6

I use the NVIDIA binary driver 367.57 selected in the "Additional Drivers" tab in "Software and updates". It works perfectly, except that the option "Prime" is not showing in NVIDIA X Server Settings. What should I do ? Should not Prime be automatically installed with the 367.57 drivers ?

  • post what nvidia card you have,sudo lshw -c display or inxi -b will show – doug Dec 7 '16 at 15:11
  • My hardware: 6700hq (so with integrated gpu) and nvidia 1070. – Henry Dec 7 '16 at 19:31
  • pretty new combo, add this ppa & install the latest driver, (375.x), maybe it'll recognize your setup for prime.. launchpad.net/~graphics-drivers/+archive/ubuntu/ppa – doug Dec 8 '16 at 1:34
  • Added the ppa and installed 375.20. Still no prime. – Henry Dec 8 '16 at 8:39
  • Make sure you have checked the 'proprietary' version of you nvidia card in Additional Drivers tab inside your Software and Updates App. If you have the nvidia X server settings already installed, then simply reboot your computer for making the PRIME tab appear. – Rituraj Joshi Jun 13 '17 at 17:40
4

Maybe the installer did not recognize that the computer has a hybrid graphics solution.
Normally the package nvidia-prime should be installed alongside the NVIDIA drivers automatically - to do it manually, open a terminal and execute the following command :

sudo apt install nvidia-prime  

Now you can find the tab PRIME Profiles in the NVIDIA X Server Settings application.

enter image description here

Update addressing your comment that the package nvidia-prime is already installed

Maybe something went wrong during the first installation process of the NVIDIA drivers.
Therefore un-install and re-install the packages nvidia-prime and nvidia-settings :

sudo apt purge nvidia-prime nvidia-settings  
sudo apt install nvidia-prime nvidia-settings  

As you did not provide further information about your graphics hardware, NVIDIA Prime is only effective when the computer has an integrated intel AND a dedicated NVIDIA graphics adapter.

Update addressing the comment in which you provided information about the hardware

As you have very new graphics hardware - using the latest stable drivers may solve the issue.

First uninstall every NVIDIA related software you have installed on your operating system :

sudo apt purge nvidia*  
sudo reboot  

After the restart install the latest official NVIDIA drivers 375.20 from the long-lived branch :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
sudo apt install nvidia-375 nvidia-prime
sudo reboot
|improve this answer|||||
  • 1
    I did "sudo apt install nvidia-prime". However, it has no effect: "nvidia-prime is already the newest version (0.8.2)." And of course, still no PRIME in NVIDIA X server. – Henry Dec 7 '16 at 14:16
  • 1
    I purged and re-installed. It does not work, no Prime tab in NVIDIA X server. My hardware: 6700hq (so with integrated gpu) and nvidia 1070. – Henry Dec 7 '16 at 18:50
  • @Henry : You might want to give the latest stable drivers from the NVIDIA long-lived branch, supporting the NVIDIA GEFORCE GTX 1070 adapter a try. I have updated the answer with instructions how to do it ... and although you said that you already have tried it, eventually just the way you did it was not successful. Additionally check whether you have to switch between the cards in BIOS - in some machines you have to enable the switchable graphics mode or manually set the graphics adapter that shall be used explicitly. :) – cl-netbox Dec 8 '16 at 11:14
  • Did carefully what you said: purge, reboot, add ppa, update, install 375, and reboot. I checked the bios, there is no such option. The last thing I see is that the integrated GPU of the processor is not seen by Ubuntu. Anyway, the system is absolutely stable and totally quiet. – Henry Dec 8 '16 at 11:32
  • @Henry : Ubuntu 16.04 comes with kernel 4.4 which is known to have issues with intel Skylake processors. You may want to consider installing kernel 4.8 which is working much better with the intel 6700 processor. Here you can find all information about the 16.04 HWE stack and the instructions how to install kernel 4.8 -> wiki.ubuntu.com/Kernel/RollingLTSEnablementStack ! Uninstall the NVIDIA drivers before and reinstall them after having installed that new kernel. There is a pretty good chance that this solves the problem. :) – cl-netbox Dec 8 '16 at 13:50
1

nvidia-prime is its own separate package that needs to be installed.

sudo apt-get install nvidia-prime

See link: How am I supposed to use nvidia-prime?

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.