7

I have been trying to put a microphone into my combined headphone/mic port and saw a video on hdajackretask . However, the device is busy when I say to apply. I can install the boot-override file but I cannot apply.

In the video, all he did was shut down alsa-mixer and he got rid of that problem. I did not start any sound devices.

Update: I noticed that pulse audio is running and maybe this effects it. However, when I shut it down, it seems to pop back up. I cannot know what is starting it. I am not sure if this is the reason.

enter image description here

5

It is pulseaudio. The problem is that it gets autorestarted immediately. So you need to edit the file /etc/pulse/client.conf.

Add these two lines or uncomment them out as needed.. (I added them up top so I can leave everything the same when I want to undo it) The default is commented and left for your editing.

autospawn = no
daemon-binary = /bin/true 

reboot and then you can turn on and off pulseaudio by using

pulseaudio --start
pulseaudio --kill

You will need to start pulseaudio the manual way since it is not auto-started until you undo your client.conf changes. You can make your changes in hdaJackretask and test them. But you will need to turn on pulseaudio. If you want to make more changes, you will need to toggle -----kill and --start respectively.

There were some other articles for Pulseaudio but this answer is specific to this question. Once you like the settings you can install the boot script and then undo all of this. Unfortunately, I could not get the pins to work in a way that was working. So my efforts were useless.

2
  • 2
    For me, the device is still busy after killing pulseaudio. How can I find the other process that keeps the device busy?
    – Alireza
    Nov 27 '17 at 10:18
  • 1
    systemctl --user stop pulseaudio.socket pulseaudio.service
    – rustyx
    Oct 10 at 12:36
1

In my case (Ubuntu Artful Ardvark/17.10), I just needed to run it as myself (no elevated privileges) and then restart Pulseaudio manually after applying the override.

1

It simply means that a program is using the audio card. Typically you may have an application opened to test the audio output, and it's the culprit locking your device.

Close it (or them), close also your web browser, and it may unlock your device.

0

I had the same issue when I tried to make my subwoofer work and followed the answer of this problem: Ubuntu 14.04 Asus G550JK SonicMaster External Subwoofer not working I ignored the error and rebooted and it works fine.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.