1

A question asked many times and yet I didn't find an answer that helped me.

I have an Apache Server running under Ubuntu 12.04.5 LTS (yes I need to update).

I have a webpage in /var/www/website/index.html

I have set the Domain Forward at my providers to
https://ip.address/website/index.hmtl

I have a .htaccess file in /home/website/ which reads

<Files ~ "^\.(htaccess|htpasswd)$">
deny from all
</Files>
Options Indexes
DirectoryIndex index.html       
order deny,allow

I have added a
LoadModule rewrite_module modules/mod_rewrite.so
into my /etc/apache2/apache2.conf

When trying to visit the site, I get the error The requested URL /website/index.html was not found on this server.

This is the first time I'm doing something like this and I'm completely at loss... Why can't I visit my Page?

UPDATE: I now set up everything as in https://debian-administration.org/article/412/Hosting_multiple_websites_with_Apache2

Now I get the error that my browser can't get a connection to the server?

UPDATE2: I now have an error.log file in my website's directory saying [Wed Dec 07 08:23:10 2016] [error] (2)No such file or directory: could not open transfer log file /home/www/website/logs/access.log.

10
  • @Terrance There is no 000-default.conf... only a 000-default and there is DocumentRoot /var/www Hm I think thats not right, right?
    – Fl.pf.
    Dec 6, 2016 at 18:37
  • @Terrance ok, but that kind of means that I only can run one website per server?
    – Fl.pf.
    Dec 6, 2016 at 18:39
  • @Terrance It didnt help either... :D
    – Fl.pf.
    Dec 6, 2016 at 18:41
  • @Terrance permissions are alright. Could it be my SSL certificates? They could be quite old... How would I check that and/or update them?
    – Fl.pf.
    Dec 6, 2016 at 18:52
  • Here's info for multiple websites: debian-administration.org/article/412/…
    – Terrance
    Dec 6, 2016 at 19:01

1 Answer 1

7

On ubuntu enabling module rewrite by running sudo a2enmod rewrite and then retart apache2 service with service apache2 restart will solve your problem

2
  • 1
    uh, a necromancer! Thank you for that, I will definitely try that out. At the moment, I run the websites with my Raspberry since they are still not in a shape to go online (where is all my time going??)...
    – Fl.pf.
    Nov 15, 2017 at 11:20
  • 1
    Thanks bilal you saved my life
    – Ajay saini
    Jul 28, 2020 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.