0

I have a folder which I want members of a group to be able to read, write, and execute in. I made a group named "potteryclass", and made it the group for the folder. I've added users "john" and "bob" to it. Here's how it looks:

$ ls -al
drwxrwxr-x 2 john potteryclass 4096 Dec  4 04:22 projects

$ getent group potteryclass
potteryclass:x:1002:john,bob

This is how I did it:

sudo addgroup potteryclass
sudo usermod -a -G potteryclass john
sudo usermod -a -G potteryclass bob
sudo chown -R :potteryclass /home/projects

but user "bob" still cannot create new files in there.

What did I miss?

Thanks

  • 3
    have you tried logging off the user and then logging back on? This is often required after modifying group settings. – stevieb Dec 6 '16 at 17:41
  • Ha, ugh that was it - after a restart it works - can you add your comment as an answer so I can accept? – user3203425 Dec 6 '16 at 18:18
  • Answer added. I'm glad that's all it was. – stevieb Dec 6 '16 at 18:28
2

After you've added a user to a group (whether it be an existing or new group), you must log that user off and log back on again for the group change to be applied.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.