0

I'm trying to boot GParted from Live USB, but Grub2 won't let me.

I've created a live usb using UNetbootin utility. The .iso file I used for creating the live usb is: gparted-live-0.27.0-1-amd64.iso.

If I open Bios when reloading, set boot priority #1 for USB drive and press save&exit, the Grub2 window gets loaded (the one where I choose the OS to boot, I have Windows and Ubuntu 14.04 installed).

Here's the screenshot from Grub2 console where I've found how my usb drive is identified ((hd0,msdos1)): enter image description here

I've looked through about a dozen tutorials but couldn't find the right solution for me.


Could you please help my to set up booting from live usb and resovle the issue I've encountered?

Update 1

I've formatted my usb drive again and used this terminal command to make a live usb:

sudo dd if=./Downloads/gparted-live-0.27.0-1-amd64.iso of=/dev/sdb1 bs=1M

Here's what I could get from Grub2 terminal (the USB drive didn't boot again): note the label of (hd0,msdos1) enter image description here

and this is something from one of the tutorials I've tried: enter image description here

  • I would suggest you check if your USB-Stick is a bootable device, first. I think there might be the problem. Can you test it on another PC? Sometimes I ran into problems with UNETBOOTIN; I usually use the dd command. – HATEthePLOT Dec 6 '16 at 17:22
  • @HATEthePLOT I've tried to use the dd command. Please, see the update of the question. – yakovenko-denis Dec 6 '16 at 17:38
  • Please try the following command to write the iso to your stick: sudo dd if=./Downloads/gparted-live-0.27.0-1-amd64.iso of=/dev/sdb bs=1M – HATEthePLOT Dec 6 '16 at 17:51
  • Not sure what you are doing. Is system BIOS or UEFI. BIOS live systems usually boot with syslinux, not grub. But UEFI does boot with grub. But that is only for booting directly from BIOS/UEFI. You may be able to do a chain entry. But you can also just directly boot ISO file one a flash drive with grub2's loopmount as a menu item in grub on your hard drive. help.ubuntu.com/community/Grub2/ISOBoot – oldfred Dec 6 '16 at 18:57
  • @oldfred I'd be happy to do so, but Grub won't let me boot from .iso. Here's my unanswered question about this: askubuntu.com/q/857250/480945 . It's really a disaster, it seems that I've tried almost all the variants of booting and none works ... – yakovenko-denis Dec 6 '16 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.