0

I run into this error occassionaly after a scheduled backup. Upon a service mysql restart ... it fails to come up.

Attempting a manual start, gives me this.

mysqld 
161125  7:40:48 [ERROR] mysqld: Can't lock aria control file '/var/lib/mysql/aria_log_control' for exclusive use, error: 11. Will retry for 30 seconds 
161125  7:40:49 [Note] InnoDB: Using mutexes to ref count buffer pool pages 
161125  7:40:49 [Note] InnoDB: The InnoDB memory heap is disabled 
161125  7:40:49 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins 
161125  7:40:49 [Note] InnoDB: Memory barrier is not used 
161125  7:40:49 [Note] InnoDB: Compressed tables use zlib 1.2.8 
161125  7:40:49 [Note] InnoDB: Using Linux native AIO 
161125  7:40:49 [Note] InnoDB: Using CPU crc32 instructions 
161125  7:40:49 [Note] InnoDB: Initializing buffer pool, size = 64.0M 
161125  7:40:49 [Note] InnoDB: Completed initialization of buffer pool 
161125  7:40:49 [Note] InnoDB: Highest supported file format is Barracuda. 
161125  7:40:49 [Note] InnoDB: 128 rollback segment(s) are active. 
161125  7:40:49 [Note] InnoDB: Waiting for urge to start 
161125  7:40:49 [Note] InnoDB:  Percona XtraDB (http://www.percona.com) 5.6.22-72.0 started; log sequence number 13113858453 
161125  7:40:49 [Note] Plugin 'FEEDBACK' is disabled. 
161125  7:40:49 [ERROR] mysqld: File '/var/log/mysql/mariadb-bin.009076' not found (Errcode: 2 "No such file or directory") 
161125  7:40:49 [ERROR] Failed to open log    (file '/var/log/mysql/mariadb-bin.009076', errno 2) 
161125  7:40:49 [ERROR] Could not open log file 
161125  7:40:49 [ERROR] Can't init tc log 
161125  7:40:49 [ERROR] Aborting
161125  7:40:49 [Note] InnoDB: FTS optimize thread exiting. 
161125  7:40:49 [Note] InnoDB: Starting shutdown... 
161125  7:40:51 [Note] InnoDB: Shutdown completed; log sequence number 13113858463
161125  7:40:51 [Note] mysqld: Shutdown complete

I have tried deleting the aria_log_control file and starting again, but the same error occurs.

mysqld_safe isn't doing it either.

 mysqld_safe 
161206 12:36:14 mysqld_safe Logging to syslog. 
161206 12:36:14 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql 
161206 12:36:16 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended 
root@server:/var/lib/mysql# mysql ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2 "No such file or directory") 

What else should I look at?

Thanks!

  • Thank you for the edit, @heynnema! I tried 4 times to get that right! – Daniel Wilson Dec 6 '16 at 16:51
  • You're welcome. The trick is the <pre> and </pre> tags. Then just minor touchup to fix some formatting problems. – heynnema Dec 6 '16 at 16:53
  • The <pre> and </pre> doesn't work in comments. Edit your original question to include your new output, include the pre tags. Delete the above comment after. – heynnema Dec 6 '16 at 17:45
  • Deleting both ib_logfile0 and ib_logfile1 got me past the first error. – Daniel Wilson Dec 6 '16 at 22:37
  • I still get the error about missing /var/log/mysq/mariadb-bin.<serial number> – Daniel Wilson Dec 6 '16 at 22:38
2

After deleting the aria_log* files and the ib_logfile* files, I turned off binary logging per http://community.rtcamp.com/t/mariadb-bin-log-eat-my-disk-space/4278/4

Mysql started ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.