1

I have been trying to mount a partition (/dev/sda4 is this detail helps) to /mnt so I can chroot into it from Ubuntu 16.04. But whenever I try to mount it I get the error:

mount: unknown filesystem type 'LVM2_member'

Now I have tried installing lvm2 with APT. I have also tried starting the lvm2-lvmetad service and socket, but I still get this same error. I have seen this answer but it was not helpful to me for two reasons:

  • Firstly, it seems to pertain to a system with multiple LVM2 partitions where in there is a need to distinguish between their labels. I have only one LVM2 partition and its label is fedora.

  • Secondly, it provides no real details on how to rename a partition group (merely says "using vgrename", as opposed to giving a specific command to do this).

If it helps here is my partition table (which I got by running fdisk /dev/sda -l):

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 70714BA5-A85F-4BEB-BA64-79D0AD3EB7B8

Device          Start        End    Sectors  Size Type
/dev/sda1        2048    1050623    1048576  512M EFI System
/dev/sda2     1050624 1154484223 1153433600  550G Linux filesystem
/dev/sda3  1920108544 1953523711   33415168   16G Linux swap
/dev/sda4  1154484224 1867401215  712916992  340G Linux LVM

Partition table entries are not in disk order.

EDIT: pvscan returns:

  PV /dev/sda4   VG fedora          lvm2 [339.94 GiB / 12.00 MiB free]
  Total: 1 [339.94 GiB] / in use: 1 [339.94 GiB] / in no VG: 0 [0   ]

while lvscan returns:

  ACTIVE            '/dev/fedora/root' [339.93 GiB] inherit
2
  • Did you try pvscan and lvscan to see if the LVM partition is recognized? Please add the output to your question.
    – ridgy
    Dec 6 '16 at 14:04
  • OK, I added the output to the question. It seems to me like they are recognizing it.
    – Josh Pinto
    Dec 6 '16 at 14:13
3

You need to mount the LVM logical disk, not the LVM physical disk. In your specific case, you want to mount /dev/fedora/root.

 fsck -p /dev/fedora/root
 mount /dev/fedora/root /mnt

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.