0

After installation of Ubuntu 16.04 LST on this PC there is no GRUB available. It seems, that this new PC has an incompatible BIOS. All hints to other ACER PCs are not usable. Will there a solution in reasonable time available?

  • I don't know what you're referring to as an "incompatible BIOS"- the XC has a UEFI BIOS. Simply disable Secure Boot, disable Fast Boot (in Windows), and create a USB for UEFI in Windows. Are you trying to dual boot? – negusp Dec 6 '16 at 13:27
  • I am trying dual boot. But your answer about the EFI BIOS of that Desktop PC is not correct. It has not a regular EFI BIOS. Therefore starting the Ubuntu ISO DVD causes 3 error messages. The first: Failed to open \EFI\BOOT\MokManager.efi - Not found. I tried every senseful adjustment of the BIOS without success. – W.Axer Dec 6 '16 at 20:29
  • Your BIOS is normal. However, because you are trying to dual-boot with an existing manufacturer-installed installation it seems that the Windows EFI partition is conflicting with GRUB. Either you completely wipe all the partitions on your HDD and reinstall, or you can be lazy and use WUBI. It adds a UEFI entry into your BIOS which you can select at boot. – negusp Dec 6 '16 at 20:35
  • Well, I tried WUBI. But the installation was stopped shortly before the end with the error message in german: process has no access to the file since it is used by another process. In my BIOS nothing has changed. When I erase SSD and HDD completely, what will happen will to the BIOS? – W.Axer Dec 7 '16 at 22:43
  • Are you trying to install on the same drive with Windows on it? Or the other drive? – negusp Dec 7 '16 at 23:53
0

I have just managed to dual boot on this machine. Suggest:

  1. Make a 16.10 startup disc on a usb stick Turn off fast boot and hibernate in Windows (both of these generate a hibernate file which can not be used by Linux)

  2. Turn off Secure boot in the UEFI "BIOS"

  3. Install Ubuntu 16.10. Boot machine - it will boot into Windows

  4. Search for cmd and open cmd for administrator Type in

    bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

  5. reboot and you will get the usual grub screen.

    This command points to the right boot manager in the EFI partition.

I found this here:https://itsfoss.com/no-grub-windows-linux

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.