First off, let me start by saying that I am well aware that many other people have asked similar questions, and have had their questions answered and their problems solved. I am here because I have attempted a range of the solutions already posted, and none of them have worked.

Some background: I am running Ubuntu 16.04 off of a flash drive. The WiFi does not work. But, it's not just that I try to connect to a network, and it doesn't connect; rather, the idea of WiFi itself seems to be a foreign concept to the system. Nowhere is there any option to even see available WiFi networks. Clicking on the network icon yields: (parentheses indicate grayed-out):

(Ethernet network)
VPN Connections→
Enable Networking – this is checked
(Connection information)
Edit connections

If I run service network-manager restart, which some guides say will fix the wifi menu, I get a notification that I am now disconnected, and more options become grayed out. I've also tried typing nm-applet in terminal and that did nothing.

One post suggested running sudo ifconfig wlp4s0 up. This did nothing, and gave the message: wlp4s0: ERROR while getting interface flags: no such device.

Running sudo modprobe -wl yields: Error: Could not insert wl: required key not available. Researching that, it seems that the error comes from having secure boot enabled. So I go into the BIOS, disable secure boot, and then run the command again, and get the same result.

After disabling secure boot, I then tried running sudo apt-get purge bcmwl-kernel-source then sudo apt-get install linux-generic bcmwl-kernel-source, rebooted, and there was no effect.

My wifi card is Broadcom BCM4312 802.11b/g/n and my PCI Id is 14e4:4365 (rev 01). This information in hand, I followed the instructions of another post, which suggested I go to /etc/pm/config and edit config.d, adding SUSPEND_MODULES="BCM4312". There was no config.d file in that directory, and I was told I did not have permission to save a file there, which makes no sense because I am the only user.

I've gone into Settings > Software and Updates, and enable the Broadcom wifi card.

Output of iwconfig:

lo    no wireless extensions
enp14s0   no wireless extensions

I'm not sure what that means.

I've tried all the steps at the following posts:

And non of them seem to work. I am not sure where to go from here. Any help would be greatly appreciated. Thank you.

  • The "no wireless extensions" message means the device isn't a wireless network device (lo is the loopback interface, and I'm assuming enp14s0 is a wired interface of sorts). For some reason the device isn't being given an interface in the system, possibly due to driver failure. Can you post dmesg output please? – Kim Phillips Dec 6 '16 at 5:19
  • The output of dmesg is over 25 pages- it's too long to post here. Anything specific you're looking for? – Dan V Dec 6 '16 at 20:47
  • Just a comprehensive detailed log of all PCI bridges, devices, wireless networking, and driver (and any more of its dependencies) possibly failing. I don't think it's a problem to post 25 pages here, it goes into a scrollable box, but if there's anything you specifically don't want to share (avant-garde h/w), then by all means trim away. One can also post places like pastebin if necessary, just not sure how long they'll last there vs. this askubuntu entry. – Kim Phillips Dec 7 '16 at 18:57
  • Please do: sudo apt-get install bcmwl-kernel-source. After it finishes, reboot and run these commands and show us the results: sudo modprobe wl (not -wl) and also: rfkill list all Welcome to AskUbuntu. – chili555 Dec 7 '16 at 22:09

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.