I have an ASUS with an AMD FX(tm)-6300 Six-Core Processor 8 gb of memory and a GTX 560 nvidia card, running ubuntu 16.10. My problem is they have updated the kernel since I installed the distro, but I am still running on an older kernel Linux 4.8.0-26-generic. The current kernel is 4.8.0-28 which i have installed. Is the reason the kernel running is older due to the nvidia drivers and do I need to switch to the free Nouveau driver and then reinstall the newest kernel and then reinstall the nvidia driver to get everything up to date. I would use the Nouveau driver but the performance is a lot slower than with the nvidia driver. Any suggestion are appreciated.

  • 1
    Have you restarted the computer? New kernels don't typically start running until you restart. If you need them to start running without a restart, the Canonical Livepatch Service is worth a look. – Chai T. Rex Dec 5 '16 at 23:36
  • In Software & Updates do you have daily updates turned on? – WinEunuuchs2Unix Dec 25 '16 at 0:21

It is generally necessary to restart the computer before the new kernel is run, because kernels are loaded in memory at the start of the machine booting.

  • I have restarted several times and that has not resolved the issue. I am going to try and change back to the free driver and see what happens on my test system first. then if get the newer kernel is running then reinstall the nvidia driver and see where it takes me. I was hoping someone has come across this with 16.10, what I am thinking is the nvidia driver is not set for the newer kernel and that is causing the fallback to the older kernel. – Richard W. Seitz Dec 6 '16 at 1:19
  • OK I just had an upgrade for the kernel to 4.8.0-30 and now after restart it is booting to 4.8.0-28, but my test bed booted just fine. strange – Richard W. Seitz Dec 6 '16 at 1:55
  • ok I reloaded the new kernel and still the same problem after i rebooted. it has to be a script or something i think. – Richard W. Seitz Dec 6 '16 at 2:22
  • can you get a picture of GRUB by holding down the Shift key till it appears, then hitting the e key and taking a picture with phone/camera? – user595510 Dec 6 '16 at 12:24
  • I will do that tomorrow morning and upload the photo. What am I looking for with this? I like to learn as I am doing. – Richard W. Seitz Dec 8 '16 at 2:31

OK I don't know why but the boot configuration file wasn't updating, when the boot menu appeared I hit the "e" key and edited the instances where it said 4.8.0-28 to 4.8.9-30 and it now has the correct boot kernel so i still don't know why it did not update but using the shift and e key gave me the option to change to the most recent kernel. BIG THANKS!!!!!, to Mark Yisri for the information it helped to solve the problem.

  • After I got this to work and load the most recent kernel, I ran boot repair available from help.ubuntu.com/community/Boot-Repair and it corrected the boot error and all is booting normally now. – Richard W. Seitz Dec 11 '16 at 0:12
  • Nice that you found a solution. Would a simple sudo update-grub not have helped? Anyway, please don't forget that you can and should accept your own answer as it's the one that solved your problem. – Byte Commander Dec 24 '16 at 23:55

I created a set of utilities to overcome this (and a few other) problems to simplify kernel upgrades.

Github Repo: https://github.com/mtompkins/linux-kernel-utilities

git clone https://github.com/mtompkins/linux-kernel-utilities
cd linux-kernel-utilities
./update_ubuntu_kernel.sh --latest

Reboot and you're done.

Not the answer you're looking for? Browse other questions tagged or ask your own question.