14

My problem is that my laptop does not wake from suspend mode. It shows me only a black screen with one sentence

[1300.001615] NVRM: Xid (PCI:0000:07:00):79, GPU has fallen off the bus.

My OS is Ubuntu 16.04 LTS. I used to work with Ubuntu 15.10 and everything was fine.

Nvidia GeForce 740M

lspci | grep -E "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
07:00.0 3D controller: **NVIDIA Corporation GK208M [GeForce GT 740M]** (rev a1)

I have to push the power button for 10 seconds to shut it down and then turn it on.

In software & updates I chose to use Nvidia binary driver - version 384.69 from nvidia 384 (open source) and this driver is listed on nvidia's site as the latest recommended driver.

The NVIDIA GeForce GT 740M supports NVIDIA Optimus technology (switchable graphics technology). Is this technology the cause of the issue?

If you have any questions, please ask me, I will answer with pleasure.

Thanks in advance ;)

  • 1
    Welcome to Ask Ubuntu! ;-) What version of the nVidia driver are you using? – Fabby Dec 5 '16 at 22:07
  • In software & updates I chose to use Nvidia binary driver - version 367.57 from nvidia 367 (proprietary, tested) – wingedRuslan Dec 6 '16 at 17:17
  • Mmmh... According to the nVidia site you should be using Version 375.20 Release Date Fri Nov 18, 2016 Operating System Linux 64-bit Language English (US) File Size 72.37 MB Can you try that one first? – Fabby Dec 6 '16 at 20:46
  • 2
    I'm using driver nvidia-378 from the repos, problem still persists. – Felipe Almeida Mar 28 '17 at 13:56
  • 1
    I have this since upgrade to 17.04. I disabled Nvidia in the meanwhile. I fear I corrupted the OS with hard restarts:(. Yesterday, the ssd was not found after one of these episodes, several trips into bios did nothing, seemingly, then a reboot succeeded. My point is avoid the poweroff button! If you have black screen of death, should try to SSH into computer and gracefully restart. No other computer? If you have Android tablet, can install ssh client. 'sudo shutdown -r now' should get it. – pauljohn32 Apr 21 '17 at 9:39
1

As was said in nvidia backlight brightness problem, it seems your solution would lie in upgrading to at least 381 as there was a critical bug in the previous versions regarding suspending.

Wish I could do more, but I think you will be solved with that.

  • I updated to 381 but the problem still the same :( – Ahmed Hamdy Sep 6 '17 at 14:59
  • It is NOT the solution! Now I am using Nvidia driver - version 384.69 from nvidia 384. The problem still exists :(( GPU has fallen off the bus. – wingedRuslan Sep 6 '17 at 20:19
  • Sorry I could not be of more help. Another case of "It works for some..." . That is the problem with bugs; they can be the same symptoms with vastly different causes. – ben-Nabiy Derush Sep 17 '17 at 2:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.