0

Not sure how to set permissions up across 3 different uses of 1 server.

I'm using samba, Transmission and plex.

Currently I use /samba/data/media as my data folder this folder is set with force user = root because it's at home, so only accessible by me. I have also added users = @smbgrp to the /etc/samba/smb.conf file

Plex is pointed at this media folder to find media files. Plex has also been added to the group smbgrp

Transmission is pointed at /home/completed-downloads/ and I rsync all new downloads to the /samba/data/media.

I'd like to setup so I can put all completed files in /**samba/data**/completed-downloads/ but my issue is that downloads are owned by user debian-transmission while the /samba/data/ directory is owned by root because of force user = root.

What would you recommend as the best way of structuring usernames and group permissions? so I don't have to manually set permission for new media files each time. I know I can use --chmod= during rsync, but I feel like there should be a better way and thought I might learn something in the process.

Options:?

1) Should I create and force user = sambauser and then add plex, debian-transmission, sambauser to each other's groups?

2) Should change the username used by each application when I install it, so all files have a common username

3) Is there a way to set the user datauser primary group as smbgrp, instead a group of it's own name?

Any other suggestions I'm not seeing?

0

From research, there are many possible answers to this question, but the one I decided up on was the following.

1) Change permissions to 2770 chmod -R 2770 /directory/ and change group owner to data, so my persmissions would read drwxrws---.

This results in any new folders created by any user to take on the group of it's parent directory.

2) I added all the users to my common data group which is smbgrp with. 'usermod -aG smbgrp plex' 'usermod -aG smbgrp debian-transmission' etc

Hope this helps someone - Do correct me if I'm wrong.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.