I have problems with my wireless card in the thinkpad x201. Everything is working fine - wireless connects and i can hit up websites. But after sleep/some time or changing the wireless AP form one to another something breaks.

lspci -vvv:

02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)
Subsystem: Intel Corporation Centrino Advanced-N 6200 2x2 AGN
Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Interrupt: pin A routed to IRQ 28
Region 0: Memory at f2400000 (64-bit, non-prefetchable) [disabled] [size=8K]
Capabilities: <access denied>
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi

dmesg short:

[ 1501.376720] iwlwifi 0000:02:00.0: Failed to load firmware chunk!
[ 1501.376731] iwlwifi 0000:02:00.0: Could not load the [0] uCode section
[ 1503.275257] iwlwifi 0000:02:00.0: Failed to run INIT ucode: -110
[ 1503.275283] iwlwifi 0000:02:00.0: Unable to initialize device.
[ 1503.277445] iwlwifi 0000:02:00.0: L1 Disabled - LTR Disabled
[ 1503.332597] iwlwifi 0000:02:00.0: L1 Disabled - LTR Disabled
[ 1503.406066] iwlwifi 0000:02:00.0: Radio type=0x1-0x3-0x1

ifconfig:

wlp2s0    Link encap:Ethernet  Hardware Adresse 00:27:10:5f:d0:38  
      BROADCAST MULTICAST  MTU:1500  Metrik:1
      RX-Pakete:0 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
      TX-Pakete:0 Fehler:0 Verloren:0 Überläufe:0 Träger:0
      Kollisionen:0 Sendewarteschlangenlänge:1000 
      RX-Bytes:0 (0.0 B)  TX-Bytes:0 (0.0 B)

Whole dmesg log can be found here: pastebin.com dmesg

The only fix so far is a reboot of the whole system. I used a few distros over the last month like gentoo,arch,debian and it happens on all of the distros. It never happend on the Windows 7 system that is installed too.

I hope someone can help me with this.

I had nightmares with Intel wifi until I ran across this. Perhaps it helps. Had to turn off power-management

Reference: How can I prevent iwconfig power management from being turned on?

Create /etc/network/if-up.d/wifi-powerman-off (chmod +x)

#!/bin/sh
# Reference: https://askubuntu.com/questions/85214/how-can-i-prevent-iwconfig-power-management-from-being-turned-on
IWCONFIG=/sbin/iwconfig
WLAN_IFACE=<<interface name>>
if [ ! -x $IWCONFIG ]; then
    exit 1
fi
if [ "$IFACE" = $WLAN_IFACE ]; then
    $IWCONFIG $IFACE power off
fi

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.