This question already has an answer here:

I am running Ubuntu 16.10 and during setup I added my data drive which is ntfs, to automount in /etc/fstab file. The entry looks like this -

UUID=EA469A60469A2D77   /alpha  ntfs-3g rw,permissions,umask=0022,user,exec,uid=1000,gid=1000,locale=en_US.UTF-8  0       0

I would like to know what I am doing wrong and how to get write access to the mounted NTFS partition.


prenx@prenx4x:~$ sudo lsblk -o NAME,FSTYPE,SIZE,MOUNTPOINT,LABEL
sdb           111.8G            
├─sdb2 swap    18.6G [SWAP]     
└─sdb1 ext4    93.2G /          
sdc             3.7T            
├─sdc2 ntfs     3.7T /zeta      Zeta
└─sdc1          128M            
sda           953.9G            
├─sda4 ntfs   952.9G /alpha     ALPHA
├─sda2 vfat      99M            
├─sda5 ntfs     450M            
├─sda3          128M            
└─sda1 ntfs     300M            Recovery

After changing any option I test it using mkdir-

prenx@prenx4x:/alpha$ mkdir a
mkdir: cannot create directory ‘a’: Read-only file system
prenx@prenx4x:/alpha$ sudo mkdir a
mkdir: cannot create directory ‘a’: Read-only file system

Also I am unable to paste or create anything in any sub-folder as well.

marked as duplicate by Fabby, Elder Geek, Eric Carvalho, 2707974, muru Apr 7 '17 at 7:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Is your "data drive" actually the C: drive in Windows, or some other drive letter? – heynnema Dec 5 '16 at 0:12
  • the /alpha shown above is C drive, the /zeta is just a data drive with no OS in it. Both are mounted as read only. – The Prenx Dec 5 '16 at 0:15
  • see my answer, below... – heynnema Dec 5 '16 at 0:27

If the NTFS drives are mounting as read-only, its probably because Ubuntu thinks their filesystems are unclean, probably due to hibernation, or a damaged file system. Do this:

in Windows

  • boot into Windows
  • open the Power control panel
  • choose change what the power buttons do
  • choose change options that are unavailable
  • uncheck fast startup
  • close the Power control panel
  • open an administrative command prompt window
  • type powercfg /h off
  • type chkdsk /f c:
  • approve to run chkdsk at next reboot
  • type chkdsk /f x: (replacing "x" with drive letters of other visible NTFS partitions)
  • reboot into Windows to let chkdsk run on drive C:
  • 1
    you can stop at the point close the Power control panel, below points quite complicated and may not need for some cases. it worked with for me with Ubuntu 16.10 and Windows 10 – vanduc1102 Feb 14 '17 at 15:45
  • 1
    @vanduc1102 No, you need to follow the complete instructions that I've given. – heynnema Feb 14 '17 at 15:46
  • This worked perfectly. Thank you! BTW I did need to run chkdsk on both drives; I checked, out of curiosity. – user178602 Jan 11 '18 at 23:51

Using rw, permissions, umask=0022, user, exec, uid=1000, and gid=1000 seems excessive.

The Official Documentation is pretty straight forward.

Something like this should work for your purposes:

UUID=EA469A60469A2D77 /alpha ntfs-3g defaults,windows_names,locale=en_US.utf8 0 0

  • I tried these options but they are also not working for me. – The Prenx Dec 4 '16 at 23:31
  • What happens exactly? Can you explain in a little further detail? Also, can you post the output of sudo lsblk -o NAME,FSTYPE,SIZE,MOUNTPOINT,LABEL in your question? – ThatGuy Dec 4 '16 at 23:32
  • Also about using all these many options, I reached here one option at a time, but none of those worked for me. – The Prenx Dec 4 '16 at 23:32
  • I know this may be a silly question, but have you done sudo apt-get install ntfs-3g? – ThatGuy Dec 5 '16 at 0:08
  • Yes. I looked at some other forums, and they suggested sudo apt-get purge ntfsprogs, sudo apt-get purge ntfs-3g, sudo apt-get install ntfs-3g which I did. Plus the partitions are getting mounted as read only. – The Prenx Dec 5 '16 at 0:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.