It goes into a black screen and then the only option left is to force shutdown (using the power button) and turn on again. Please help as it is really annoying and I have to shut down every time I need to close the laptop or transport it.

Laptop Model: Acer Aspire E 15 (E5-573-5108)

  • 1
    I have the feeling that suspend features has always been a problem. I'm using Ubuntu on laptop since 10.04, it always didn't quite worked correctly. At present I stick to 14.04 for stability reasons, but laptop (Dell) still crashes once in a while at resume. Probably has to do with hardware handling. – kebs Dec 4 '16 at 21:50

As discussed in this answer, the problems about suspend features in Ubuntu are actually a bug. I don't know if it is related but Linux Mint disabled the suspend feature as well.

My advice is to wait till they solve before trying it, since only specific hardware devices are affected by this issue. There is a discussion in here talking about that.

| improve this answer | |
  • 4
    Thanks for the answer! I tried upgrading my Kernel according to the quoted answer and I think that has solved the issue. Or at least, it's not going to limbo for now. Will see if that occurs again. – Sandeep C Dec 4 '16 at 17:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.