2

I know this question was proposed in the past but I tried almost everything. I don't know if my problem is more complicated or I am missing something.

In my computer I have a big ntfs partition in which I keep files both for windows 10 and ubuntu. When I set the thing the first time I already had problems to write on it using linux but with the guides I managed to fix it. The problem is that I lost the ability to write again and I don't know why. I already tried to manually modify fstab and to use NTFS configuartion tool to set the permissions.

This is my fstab file; the partition is sda7

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

#Entry for /dev/sda5 :
UUID=4f83e373-2a7d-442b-8ad3-8d5929a8ddaa   /   ext4    errors=remount-ro   0   1
#Entry for /dev/sda1 :
UUID=080EEE880EEE6E5E   /media/Riservato_per_il_sistema ntfs-3g defaults,locale=en_US.UTF-8 0   0
#Entry for /dev/sda7 :
UUID=6BB0D79157E7DFD1   /media/Storage/ ntfs-3g defaults,nodev,nosuid,locale=en_US.UTF-8    0   0
#Entry for /dev/sda2 :
UUID=B01EF20D1EF1CC7A   /media/sda2 ntfs-3g defaults,locale=en_US.UTF-8 0   0
#Entry for /dev/sda6 :
UUID=8c082106-53f1-409c-8347-df226cd0b95d   none    swap    sw  0   0

I also tried to modify the ownership with

    cd /media/Storage/
sudo chown -R -v username:username *

but the result was this answer for every file and folder

chown: changing ownership of 'Windows': Read-only file system
failed to change ownership of 'Windows' from root:root to username:username

Is someone able to give me any suggestion?

EDIT: output of blkid aftes step1

/dev/sda1: LABEL="Riservato per il sistema" UUID="080EEE880EEE6E5E" TYPE="ntfs" PARTUUID="fd65e542-01"
/dev/sda2: UUID="B01EF20D1EF1CC7A" TYPE="ntfs" PARTUUID="fd65e542-02"
/dev/sda5: UUID="4f83e373-2a7d-442b-8ad3-8d5929a8ddaa" TYPE="ext4" PARTUUID="fd65e542-05"
/dev/sda6: UUID="8c082106-53f1-409c-8347-df226cd0b95d" TYPE="swap" PARTUUID="fd65e542-06"
/dev/sda7: LABEL="Storage" UUID="6BB0D79157E7DFD1" TYPE="ntfs" PARTUUID="fd65e542-07"

EDIT2:fstab at the beginning of step#3

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

#Entry for /dev/sda5 :
UUID=4f83e373-2a7d-442b-8ad3-8d5929a8ddaa   /   ext4    errors=remount-ro   0   1
#Entry for /dev/sda1 :
#UUID=080EEE880EEE6E5E  /media/Riservato_per_il_sistema ntfs-3g defaults,locale=en_US.UTF-8 0   0
#/dev/sda7  /media/Storage  ntfs-3g defaults,nodev,nosuid,locale=en_US.UTF-8    0   0
#/dev/sda7  /media/Storage/_    ntfs-3g defaults,nodev,nosuid,locale=en_US.UTF-8    0   0
#Entry for /dev/sda2 :
#UUID=B01EF20D1EF1CC7A  /media/sda2 ntfs-3g defaults,locale=en_US.UTF-8 0   0
#Entry for /dev/sda6 :
UUID=8c082106-53f1-409c-8347-df226cd0b95d   none    swap    sw  0   0
  • In Windows, start an administrative command prompt window, and type chkdsk /f d: changing the "d" to the correct drive letter for this ntfs partition. Is this your C: drive, or some other drive letter? Then try to write in Ubuntu. If that works, I'll give you the complete procedure you'll need to follow. – heynnema Dec 4 '16 at 15:20
  • I did it but when i tried to restart to switch to ubuntu again the computer remained stucked on the windows screen that normally appears for updates. It says "preparing windows do not turn off the computer" should I wait? – Berker Dec 4 '16 at 15:48
  • Yes, wait, it's doing Windows updates... unrelated to the problem we were trying to solve. These updates may take a while, so be patient. You didn't say what drive letter was the one having problems in Ubuntu. Was it C:, or something else? Are you running Windows 10? – heynnema Dec 4 '16 at 15:50
  • Yes sorry! It' s not C: it's E: and I am running windows 10 – Berker Dec 4 '16 at 15:56
  • 1
    Possible duplicate of Can't mount NTFS partition with write permissions – Andrea Lazzarotto Dec 5 '16 at 13:42
1

New problem that didn't exist before... May be related to Windows update that just ran...

If Ubuntu continues to fail to boot...

step #1

  • power cycle the computer and remove all USB devices
  • at the GRUB menu, choose Ubuntu Advanced Options
  • select root access
  • type sudo fsck -f /
  • run fsck more than once if there are errors
  • type sudo mount -o remount,rw /
  • type sudo pico /etc/fstab
  • use the arrow keys to move around
  • place # comment markers at the beginning of the lines that start with:
    1. UUID=080EEE880EEE6E5E
    2. UUID=6BB0D79157E7DFD1 (we'll re-enable this one later)
    3. UUID=B01EF20D1EF1CC7A
  • type control-o to save, enter to use the same filename, and control-x to exit pico
  • reboot Ubuntu (should boot fine now)
  • start terminal from the Unity dashboard
  • type sudo blkid and copy/paste output into your original question
  • quit terminal

step #2

  • boot into Windows
  • open the Power control panel
  • choose change what the power buttons do
  • choose change options that are unavailable
  • uncheck fast startup
  • close the Power control panel
  • open an administrative command prompt window
  • type powercfg /h off
  • type chkdsk /f c:
  • approve to run chkdsk at next reboot
  • reboot into Windows to let chkdsk run

step #3

  • boot into Ubuntu
  • open terminal from the Unity dashboard
  • type sudo gedit -H /etc/fstab
  • remove the # marker from the line starting with #UUID=6BB0D79157E7DFD1
  • save the file and quit gedit
  • reboot Ubuntu

step #4

You mis-edited /etc/fstab. Here's what it should look like when you're done...

# /etc/fstab: static file system information.
#
#                

#Entry for /dev/sda5 :
UUID=4f83e373-2a7d-442b-8ad3-8d5929a8ddaa   /   ext4    errors=remount-ro   0   1
#Entry for /dev/sda1 :
#UUID=080EEE880EEE6E5E   /media/Riservato_per_il_sistema ntfs-3g defaults,locale=en_US.UTF-8 0   0
#Entry for /dev/sda7 :
UUID=6BB0D79157E7DFD1   /media/Storage/ ntfs-3g defaults,nodev,nosuid,locale=en_US.UTF-8    0   0
#Entry for /dev/sda2 :
#UUID=B01EF20D1EF1CC7A   /media/sda2 ntfs-3g defaults,locale=en_US.UTF-8 0   0
#Entry for /dev/sda6 :
UUID=8c082106-53f1-409c-8347-df226cd0b95d   none    swap    sw  0   0
| improve this answer | |
  • I tried to rerun sudo fsck -f / but all the times it stops with the error "e2fsck: Cannot continue, aborting" after "/dev/sda5 is mounted" – Berker Dec 4 '16 at 17:15
  • Did you follow my answer exactly? Do you have a Ubuntu Live DVD? – heynnema Dec 4 '16 at 17:22
  • I should have to. So: after the message of the recovery mode I pressed enter and I obtained access to a command line starting with @root. Then I inserted the command and this was the result. – Berker Dec 4 '16 at 17:34
  • Ah, you're getting dumped directly into the root prompt. I've edited my steps again... start from the beginning and this time it should work. My error. If however, it throws any more similar errors, skip the fsck and go straight to the sudo mount step. – heynnema Dec 4 '16 at 17:50
  • Ok new error: arrived to the gedit part it answer with "failed to connect to Mir: Failed to connect to server socket: no such file or directory. Unable to init server: Could not connect: Connection refused." Anyway I have the live cd and if I select "try ubuntu" now I have full access to the partition. Should I just reinstall Ubuntu or this would mess with my Windows installation? – Berker Dec 4 '16 at 18:17
4

In most of the cases the problem is with fast startup feature of Windows 10. If it is the case you have to simply disable fast startup on Windows.

Here are the steps.

  1. Type Control Panel in the search box.
  2. Click Control Panel.
  3. Click Power Options.
  4. Click Choose what the power buttons do.
  5. Click Change settings that are currently unavailable.
  6. Scroll down to Shutdown settings and uncheck Turn on fast startup.
  7. Click Save changes.
| improve this answer | |
  • 1
    And you also need to open an administrative command prompt window and disable hibernation by typing powercfg /h off. This problem just changed while I was in the middle of fixing the original problem. – heynnema Dec 4 '16 at 17:05
  • 1
    This should be the accecpted answer -- this fixed the problem for me. I dual boot Windows / Ubuntu, and I've known that booting into Ubuntu after hibernating the Windows side put some sort of lock on the shared partition, but was not aware of this new "fast startup" option in Windows 10, which seems to do something similar. Thanks @Yasas ! – Garrett Simpson May 9 '19 at 3:29
0

I have ubuntu studio installed with gnome and xcfe and ubuntu studio desktop environments installed.I have this same issue with genome environment but no in others... So my suggestion is to install an alternate desktop environment and try again.

OR

you could also try launching nautilus as root and then try doing whatever you want...

| improve this answer | |
  • Wrong answer on so many counts. – heynnema Dec 4 '16 at 19:53
  • well...it worked for me :/ – Abir Roy Chowdhury Dec 4 '16 at 19:56
  • 1
    It's like saying... "my engine is making a funny noise"... solution... "lets change the spare tire... or... clean the windshield". You solution has nothing to do with the problem. Read my answer, to see what was involved. – heynnema Dec 4 '16 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.