1

Okay, so I'll try to explain my problem as well as I can.

A long time ago I was able to use Linux normally, and for more than 6 months I used Linux as my primary operating system. After some kernel updates whenever I tried to get into a distribution my pc froze, so I got back to Windows.

Not a long time ago I discovered that the only way to install and use Ubuntu (or other distributions) was to turn off ACPI either from the Bios whenever I entered the distribution or just install the distro with ACPI turned off.

My problem is: I lately had to change my Hard Drive and on this one I installed Windows using around 400 GB and Ubuntu on a partition of 100 GB. I installed Ubuntu with the option ACPI off, by pressing F8 or F6 when booting the first time.

The problem is that with ACPI off, whenever I am on Ubuntu, my hard drive makes some noises, something like scratching or is at least working way too much for what I'm doing (using the browser to read a few things and writing code).

This does not happen on Windows at all. I can run all kind of programs at the same time and I hear nothing from my HDD.

My questions are: is that sound dangerous for my HDD? Is there a way to make Ubuntu run with ACPI on? Or is there a way to stop the sound from my HDD when using Ubuntu? Should I change to something different, like Linux Mint or Ubuntu Mate?

I should also mention that my computer is pretty old (2008), but I never really had this kind of problem with it. Everything just worked fine with Linux or Windows on it until the kernel updates.

Thank you for your time!

3
  • It's a hard disk failure, or at least some bad blocks on the disk. Start the Disks app and run the SMART diagnostics. Report back. – heynnema Dec 4 '16 at 15:35
  • @heynnema How to start this app? Should I install it first? – Line May 1 '20 at 7:28
  • @Line it's a gui app that comes with Ubuntu. Or you can start it from terminal with gnome-disks – kurja May 1 '20 at 7:46
0

I do not know a definite answer, as this is a very complex problem. It sounds like there may be an issue with your motherboard just because it is so old, and was also designed for older protocols.

Even though you replaced your hard drive, the clicking could be the motherboard with a broken circuit or corrupt code sending erroneous signals to the hard drive and causing the hard drive to move the read/write heads too far in either direction. I would be interested to know if other distributions caused the same issues for you.

As for if it is dangerous, it could be. Hard drives do not normally make noises when running, and if yours is then I would try to figure out the issue before running it too long in case damage could occur.

5
  • Hello, and thank you for your answer. Right now I'm writing from an Ubuntu Mate Live USB and the sound disappeared, at least for now... it may be because of the Ubuntu distro, but I'm not sure. Also, I have another question, if it's okay. It's safe to disable ACPI whenever I use Linux? Sadly I can't install or even use the Ubuntu Mate distro with the ACPI off, so I have to disable it whenever I'll use any Linux distribution... do you think that may be dangerous or it's okay? I've researched myself, but while some say ACPI is good, other say ACPI is useless and should be disabled. – Raikuhen Dec 4 '16 at 14:59
  • I take back what I said - the noise is still there, at least when I live boot Ubuntu mate. Also, I should correct myself here and in the question - the sound is more like a scratching one, not clicking. – Raikuhen Dec 4 '16 at 15:05
  • 1
    "I do not know a definite answer" tells me that this is a somewhat verbose comment, not an answer. It doesn't solve the problem. – heynnema Dec 4 '16 at 15:40
  • Why is everyone SO defensive on comment vs answer? I was attempting to help answer his question. I don't see your comment solving his problem, either heynnema. At least I attempt. </end rant> I don't think running without acpi is necessarily good or bad, its just another protocol to interface with the motherboard. I would say you could run without it if it causes you issues with your older motherboard. It may be designed to use APM, the older standard. – Kyle H Dec 5 '16 at 16:57
  • @heynnema because people come here to get an answer, and you give them hope that you provided one – Line May 1 '20 at 7:27
0

Changing hard disk acoustic level helped me:

sudo hdparm -M 128 /dev/sda

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.