1

I installed Ubuntu 14.04 LTS after a long time with Windows. Now I can't shutdown or restart Ubuntu from the GUI reliably.

I've seen some posts about grub and haven't found anything useful. But, it shuts down properly when I perform

sudo shutdown -v -h now

After that, subsequent shutdowns execute correctly from the GUI until I install a new application through the terminal.

NOTE: Windows 10 was installed first, then the Ubuntu was installed.

3
  • would a fresh install be out of place to see if the issue goes away? – George Udosen Dec 3 '16 at 21:26
  • Why install 14.04, when 16.04.1 is the current LTS distribution at ubuntu.com/download/desktop ? – K7AAY Dec 3 '16 at 21:47
  • Well my friend told me that 16,04 is less stable than 14.04? And I failed to install it through USB. When I select try Ubuntu or install Ubuntu both of them stuck on the loading screen just like the problem with shutdown. Something is wrong I can feel it :)) at Last I'm gonna have to wipe all drive and put only Ubuntu on it %) – Sencer Yazıcı Dec 4 '16 at 7:21
0

Try setting these boot parameters, as ACPI and APM often can be problematic.

sudo -H gedit /etc/default/grub 

to change

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force apm=power_off"  

then save the file and exit gedit.

Then, do

sudo -H gedit /etc/modules  

and add

apm power_off=1  

and save the file. Then do

sudo update-grub 

and reboot. Should that not resolve the issue, please record the shutdown using your smartphone in slo mo mode a la Ubuntu 16.04.1 : shutdown/reboot stuck on "[ok] stopped thermal daemon service"

3
  • I tried your suggestion but there is nothing like that when shutting down, my lines end on "will now halt" except for that line every line is "OK". I mean there is nothing to record. Also I tried your method, restarted through terminal no problems since. I installed an application and it does not shutdown through the gui, again. – Sencer Yazıcı Dec 4 '16 at 7:40
  • 1
    I found the problem!! I just deleted the app "guake" and it shuts down correctly. I believe it was waiting to close guake but fails so. I like guake is there a solution :) – Sencer Yazıcı Dec 4 '16 at 7:43
  • So do I ! Then, please edit your question and note what you have done since you wrote it, and that you found a guake inspired shutdown failure. Reinstall guake and see if problem returns. Also please change title to add "because of guake" at end. I will look for a solution, but this is progress ! – K7AAY Dec 5 '16 at 13:27
0

In my case the problem was solved by installing Nvidia graphics card drivers (the supported version - that's important). On some of new computers driver problems occur. Luckily I was able to figure it out somehow and installed the driver. Thanks for help.

1
  • 1
    Welcome to Ask Ubuntu! I recommend to edit this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on AskUbuntu.) – David Foerster Jun 3 '17 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.