1

When I insert a USB external storage, it automounts to /media/usb0 and /media/usb1 (depending on if I have a usb drive already connected). When these drives are mounted, they are owned by root, so the user doesn't have write access.

When I insert the same drive into another Ubuntu machine, it mounts to /media/<username>/0A83-5E97. This is owned by <username>, so I have write access as expected. However, I don't know how to get this behavior in my other machine (this is the behavior that I want, and I don't want to have to run chown every time I connect a usb device).

I have followed most of the suggestions on the community page (https://help.ubuntu.com/community/Mount/USB) including toggling the settings using dconf-editor (org.gnome.desktop.media-handling/automount). When auto-mount is enabled, I will often get an gui error message saying "Unable to mount 62 GB Volume, Device /dev/sdg1/ is already mounted at '/media/usb1'."

I have looked at the outputs from sudo lsblk -fm and the results are the same from the two computers (with the exception of the "mountpoints", obviously). I have also looked at the output of dmesg, but these look the same on both computers. Neither of the computers contain any mounting stuff for usb drives in /etc/fstab.

My best guess is that some other program is mounting the drive to /media/usb* before gnome mounts it to /media/<username>/, but I'm not sure how to find out what program this is. I had thought it was some xfce process, but I believe I've removed all xfce stuff on that machine.

On both machines I am using Ubuntu 16.04.

2
  • "followed most of the suggestions"? Which of the steps of which of the instructions did you skip? Why?
    – waltinator
    Dec 3, 2016 at 17:35
  • Sorry, I tried everything under the "automount" section that was relevant. In the next paragraph I mentioned the things that I tried.
    – rottweiler
    Dec 3, 2016 at 17:43

1 Answer 1

3

Removing usbmount fixes the problem:

sudo apt-get remove usbmount

I'm not sure when/how I installed this, but it appears to be mounting usb devices to /media/usb* before gnome does its standard mounting to /media/<username>/.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .