0

I'm a complete noobie when it comes to linux so appologies if I'm missing something obvious. I'm trying to install ubuntu server 16.10 on a home file server I'm putting together.

During the add-module phase of the installation where i'm given the option to install openssh, samba file server and such, I get an error message and the process doesn't complete. I'm able to finish the installation of the OS and can reboot into the terminal but when I try to sudo apt-get install openssh I'm asked to insert the ubuntu-server cd yakety-yak 16.10. I don't have an optical drive so this is impossible.

I found a suggestion online saying to remove '/cdrom/d' from etc/apt/sources.list. I did that but with no effect. I ran some grep searches on the sources.list file and it appears to actually be empty.

I don't have this problem when I install ubuntu desktop. I want to install a RAID array so I think I need to get ubuntu server working. Any help is greatly appreciated.

  • "I ran some grep searches"? Why don't you just 'cat /etc/apt/sources.list' to see if it really is empty. – Bruni Dec 3 '16 at 16:39
  • Good to know. I was trying nano and gedit but they weren't installed. I'll have to look up cat. thanks – Rob Dec 3 '16 at 19:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.