11

I have read that you can change alert sound for notification if you select it at Settings/Sounds/Sounds Effect, but in the selecting area I only have default option and nothing more.

sound settings

I want my alert sound to be the one at

/usr/share/sounds/freedesktop/stereo/complete.oga

Here is my folder usr/share/sounds/:

usr sound folder

Moreover, in /usr/share/sounds/ubuntu/notification folder there are 10 files, but why aren't they displayed in alert sound settings?

  • Maybe some of the sound theme files are broken or not cached properly. Can you try to reinstall all the packages that have files in /usr/share/sounds (dpkg-query -S /usr/share/sounds | cut -d: -f1 | tr -d , | xargs sudo apt-get install --reinstall). That should restore corrupted files and trigger a cache rebuild. – David Foerster Feb 10 '17 at 12:17
  • Related: askubuntu.com/questions/654115/… – Elder Geek Feb 10 '17 at 14:51
2

The short answer is, things don't work that way any more. Each program has its own settings for that (and they are often not configurable via GUI, and are VERY hard to find in any other manner.) This includes your file manager (which might also use portions of a different "program" to function) or any system program, many of which were not designed to be configurable for the GUI let alone sounds! Blame it all on ALSA and Linux community fragmentation, I guess.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.