1

First of all, I've been trying to run Steam for the last few days. Every time I started Steam, the icon only appears for a moment, then it closes. When I checked the process through the system monitor, it is marked as sleeping. So I started it through the terminal, and it shows this:

$ steam
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2016-12-03 17:10:00] Startup - updater built Jun 16 2014 11:16:02
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

From what I read here, putting the env LD_PRELOAD='/usr/$LIB/libstdc++.so.6' DISPLAY=:0 command before steam, could get it running, and it ends up like this:

$ env LD_PRELOAD='/usr/$LIB/libstdc++.so.6' DISPLAY=:0 steam
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2016-12-03 17:12:41] Startup - updater built Jun 16 2014 11:16:02
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

I've also read fromthe same link that deleting the libstdc++.so.6 link might make it work, but apparently the said directory does not exist in my device, which might explain why the output is same.

Would anyone point me to the right direction?

  • "libGL error: failed to load driver: swrast" What is your GPU and what driver do you have? – Mark Kirby Dec 3 '16 at 11:13
  • @MarkKirby My GPU is NVIDIA GeForce 840M, driver version 375. – nugie Dec 3 '16 at 11:23
  • Go in to the nvidia settings app and make sure you are using that chip and not the Intel one, in the prime section, this should fix the error. – Mark Kirby Dec 3 '16 at 11:24
  • @MarkKirby It's already set as 'NVIDIA' in the PRIME Profile when I opened the settings. – nugie Dec 3 '16 at 11:34
  • OK try changing the driver version sudo apt-get purge nvidia* && sudo apt-get install nvidia-340 This may help as your chip is older but you are trying a newer driver. If this does not help, see here for some debugging askubuntu.com/a/566522/75060 Basically, your issue is steam is trying to load the swrast software renderer and that is not good enough for steam. – Mark Kirby Dec 3 '16 at 11:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.